Bug 9669 - Publish Application in Visual Studio does not use the keystore key
Summary: Publish Application in Visual Studio does not use the keystore key
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL: https://xamarin.desk.com/agent/case/2...
Depends on:
Blocks:
 
Reported: 2013-01-18 08:14 UTC by dean.ellis
Modified: 2016-08-03 15:23 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description dean.ellis 2013-01-18 08:14:11 UTC
Publishing an application in MonoDevelop and Visual Studio results in different .apks. 

I unzipped the apk files and noticed that the .RSA and .SF files are different between the two apk's. The apk published from MD has names similar to my keystore, but the apk from VS has named the two files ANDROIDD.RSA and ANDROIDD.SF. It looks like Visual Studio is not using the keystore names/keys. 

Original case

https://xamarin.desk.com/agent/case/23090
Comment 1 dean.ellis 2013-01-18 14:13:32 UTC
This issue is that Visual Studio was trying to re-sign and already signed package, the signing tool was ignoring the new keys and using the old ones.

Fixed in master/44eae0a9e4