Bug 9124 - Build using xbuild fails with CultureNotFoundException or NullReferenceException when external referenced assemblies are changed.
Summary: Build using xbuild fails with CultureNotFoundException or NullReferenceExcept...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General (show other bugs)
Version: Trunk
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-12-23 13:06 UTC by David McFarland
Modified: 2013-01-02 11:32 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Comment 1 David McFarland 2012-12-27 20:39:10 UTC
This is WONTFIX in mono: 
https://bugzilla.xamarin.com/show_bug.cgi?id=9128

So I've opened a bug in xbuild: 
https://bugzilla.xamarin.com/show_bug.cgi?id=9146
Comment 2 Alan McGovern 2013-01-02 11:25:35 UTC
I'm closing this as it is not a bug report per se and both bug #9128 and bug #9146 have been dealt with. Thanks for taking the time to file the issues.
Comment 3 David McFarland 2013-01-02 11:32:52 UTC
There's still a bug here, but it's much less severe.  As long as the external builder is running, the dependent assemblies will not be updated, because it (the external build mono process) still has the original assembly loaded.  It should only affect the up-to-date status of the project, and not the actual build process.

I'm not sure if the assembly metadata is used for anything else in the external builder.