Bug 8813 - Missing DMCS.bat compatibility shim for Mono 3 on Windows
Summary: Missing DMCS.bat compatibility shim for Mono 3 on Windows
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: packaging (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Duncan Mak
URL:
: 4590 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-06 13:47 UTC by Oisin Grehan
Modified: 2013-09-03 18:08 UTC (History)
8 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Oisin Grehan 2012-12-06 13:47:49 UTC
MCS has replaced DMCS for targeting -sdk:4, and a dmcs bash script exists for back compat. However, a corresponding dmcs.bat file is missing for Mono on windows. This is true as of 3.0.2 beta. The following batch file will do the job:

REM dmcs.bat compatibility shim for mcs
@echo off
call mcs -sdk:4 %*

Cheers.

-Oisin
Comment 1 Zoltan Varga 2013-08-20 18:28:40 UTC
*** Bug 4590 has been marked as a duplicate of this bug. ***
Comment 2 Mark 2013-08-26 14:28:05 UTC
We are encountering this. DMCS.bat is not installed by the windows installer.
It would seem like developers mostly build monodevelop themselves. When it is
built DMCS.bat is installed correctly. Maybe that is why more people have not
reported this. 

When using MonoDevelop  or XBuild from a command line in Windows, it reports
that dmcs.bat is missing. It can be created by hand of course.

Take, e.g. the attached project. It requires that I set MonoDevelop to use
xbuild instead of its internal building mechanism as the internal mechanism
does not compile resource files. The target .NET framework is also set to Mono
.NET 4.0 which I think is related to using dmcs.bat.

We can provide a test project that demonstrates this but it shouln't be
necessary. DMCS is not getting installed. It needs to be in the installer. 

This is a year old and there does not seem to be any movement. Shouldn't it be
fixed?

This is a duplicate of 7301 also.
Comment 3 Duncan Mak 2013-09-03 17:22:59 UTC
I checked the Windows package made today and I see that dmcs.bat is already in the installer.

We got another bug right now where mono isn't being renamed correctly to mono.exe, but I just fixed that.

The goal is for Mono 3.2.3 packages to be correct. It should come out late this week at the earliest, or some time next week.
Comment 4 Mark 2013-09-03 18:08:38 UTC
Great. Thanks!

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.