Bug 8406 - If activation app fails, error message from installer is cryptic.
Summary: If activation app fails, error message from installer is cryptic.
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 4.3.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-11-14 14:46 UTC by PJ
Modified: 2012-11-15 17:40 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description PJ 2012-11-14 14:46:53 UTC
After experiencing a failed activation (for instance, from bug 8405), the installer should have a relevant error message.


Steps to reproduce:
Install 4.3.27 with an expired license
When prompted to enter an upgrade code, enter nothing and press [Activate]
When the Activation app tells you it succeeds (bug 8405), press Ok.

Expected behavior:
Installer should have an error message that describes the issue and or solution

Actual behavior:
The error description say: "The specified message could not be found for the index 16"


MFA 4.3.27
Comment 1 PJ 2012-11-14 14:47:08 UTC
Screencast of actual behavior: http://screencast.com/t/NKWcmgNLd
Comment 3 PJ 2012-11-15 16:03:42 UTC
Yes it's there. And it looks like message 16 is included:

"16" = "Installation cannot proceed without completing activation. ERR16"
"17" = "Installation cannot proceed without completing activation. ERR17"
"18" = "Unexpected error. Please contact android@xamarin.com"


Hopefully that makes the whole situation murkier!
Comment 4 Jonathan Pryor 2012-11-15 16:42:27 UTC
I'm going to guess that it's this; lines need to be ';'-terminated:

    http://lists.apple.com/archives/xcode-users/2005/Jun/msg00039.html

For example:
http://code.google.com/p/macfuse/source/browse/trunk/core/10.4/packaging/macfuse-core/Install_resources/InstallationCheck.strings?r=1627

What's odd is that this worked before...right? Would be interesting to see if 4.2.x exhibits this bug or not, as the xcode-users email suggests that this change was done in _2005_...
Comment 5 Jonathan Pryor 2012-11-15 17:40:00 UTC
Fixed in monodroid-4.4-series/5337adc8.

Note You need to log in before you can comment on or make changes to this bug.