Bug 84 - Debugger hover watch window wrongly calculates screen size
Summary: Debugger hover watch window wrongly calculates screen size
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger (show other bugs)
Version: Trunk
Hardware: PC Linux
: Lowest normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2011-07-27 11:42 UTC by Marek Safar
Modified: 2016-07-13 14:42 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot (53.32 KB, image/png)
2011-07-27 11:42 UTC, Marek Safar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Marek Safar 2011-07-27 11:42:49 UTC
Created attachment 24 [details]
Screenshot

Sreenshot attached
Comment 1 Mikayla Hutchinson [MSFT] 2011-08-29 15:07:09 UTC
It's not clear from the screenshot what the problem is. Can you include a more complete screenshot? What dektop environment is this?
Comment 2 Marek Safar 2011-08-29 16:48:21 UTC
The screen-shot is not perfect but it happens with any linux distro which has bottom task bar. IIRC this was ubuntu 11.04 with classic theme
Comment 3 Mikayla Hutchinson [MSFT] 2011-11-15 12:31:20 UTC
I don't have a linux machine. Could you please describe the problem and provide a better screenshot?
Comment 4 Marek Safar 2011-11-15 13:50:22 UTC
The problem is visible on the screenshot. The hover window height is larger than visible screen height.
Comment 5 Mikayla Hutchinson [MSFT] 2011-11-17 11:40:21 UTC
The problem is that the debugger tooltip's size and position calculation uses the full monitor geometry, not the "usable" geometry (i.e. considering the Gnome docks). This isn't a problem for context menus because they show above the dock, but the debugger tooltip is hidden beneath the dock.
Comment 6 Jeffrey Stedfast 2011-12-13 14:37:56 UTC
fixed in git
Comment 7 xamarin-release-manager 2016-07-13 14:42:09 UTC
Fixed in version 6.1.0.5135 (cycle8)

Author: Eric Maupin
Commit: 2419251a255c8de8cc148f8c0d24f9e067e57db0 (xamarin/ios-sim-sharp)
Included in Commit: 7aef028bb648590c60ad1c6d09183bb79c84d591 (mono/monodevelop)