Bug 8285 - Constants in SerialPort.DiscardInBuffer and SerialPort.DiscardOutBuffer
Summary: Constants in SerialPort.DiscardInBuffer and SerialPort.DiscardOutBuffer
Status: VERIFIED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-11-08 13:48 UTC by Alex
Modified: 2012-12-11 08:39 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Alex 2012-11-08 13:48:12 UTC
Hi,

While experimenting with Mono on Windows I have run across an issue in SerialPort.DiscardInBuffer and SerialPort.DiscardOutBuffer methods. I checked the source code of WinSerialStream.cs (Mono 2.11.4) and found that both methods use costant value PurgeRxClear while DiscardOutBuffer should be using PurgeTxClear instead.

Apart from that PurgeRxClear and PurgeTxClear are defined wrongly as follows

const uint PurgeRxClear = 0x0004;
const uint PurgeTxClear = 0x0008;

while according to MSDN they should be

const uint PurgeRxClear = 0x0008;
const uint PurgeTxClear = 0x0004;

Please correct this issue in WinSerialStream.cs because now it is only possible to clear the Tx buffer of the serial port. Also interoperabilty with .NET is broken due to this issue.
Comment 1 Marek Safar 2012-11-11 10:54:56 UTC
Fixed in master

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 8285 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: