Bug 753 - [CorDebugger] Debugger on windows crashes if platform option is not set to x86
Summary: [CorDebugger] Debugger on windows crashes if platform option is not set to x86
Status: CONFIRMED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger (show other bugs)
Version: Trunk
Hardware: PC Windows
: Low normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
URL:
: 13337 13508 19064 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-12 06:16 UTC by Lluis Sanchez
Modified: 2016-11-05 05:31 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 753 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Lluis Sanchez 2011-09-12 06:16:39 UTC
The Windows debugger crashes if the target platform is not correctly set to x86. MonoDevelop should check the options and not allow debugging if that option is not set (64bit systems)
Comment 1 Marius Ungureanu 2013-09-16 17:19:58 UTC
*** Bug 13508 has been marked as a duplicate of this bug. ***
Comment 2 Marius Ungureanu 2013-09-16 17:21:12 UTC
I think this can be solved by spawning a remote process of mdbg to handle debugging in our selected architecture.

I'll take a look at this sometime soon.
Comment 3 Marius Ungureanu 2013-09-23 13:49:59 UTC
*** Bug 13337 has been marked as a duplicate of this bug. ***
Comment 4 David Karlaš 2014-05-16 06:49:17 UTC
*** Bug 19064 has been marked as a duplicate of this bug. ***