Bug 7499 - Mono ARMv7 and LLVM
Summary: Mono ARMv7 and LLVM
Status: RESOLVED DUPLICATE of bug 1102
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: 6.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2012-09-27 08:19 UTC by Luigi Saggese
Modified: 2012-10-22 07:52 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Verbose Output (355.87 KB, text/rtf)
2012-09-27 08:19 UTC, Luigi Saggese
Details
Test Project (5.39 KB, application/octet-stream)
2012-10-01 04:34 UTC, Luigi Saggese
Details
Verbose Output Test Project (79.22 KB, application/msword)
2012-10-01 04:34 UTC, Luigi Saggese
Details
Right Test Project (7.76 MB, application/octet-stream)
2012-10-01 04:48 UTC, Luigi Saggese
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 1102

Description Luigi Saggese 2012-09-27 08:19:20 UTC
Created attachment 2635 [details]
Verbose Output

I'm updating my app to ios6 and i having following problem

building application with ARMv7 is not possible to use the flag LLVM ... (error MT3001)
My system configuration is

MonoDevelop 3.0.4.7
MonoTouch 6.0.0.0
Mono 2.10.9

Reference to question:
http://stackoverflow.com/questions/12514102/mono-armv7-and-llvm?lq=1
http://stackoverflow.com/questions/12508826/ios-6-mono-and-backward-compatibility
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-09-27 08:24:05 UTC
Zoltan, this looks like your area:

/var/folders/_3/x0_zyy9j0r5_gg94nc3r51zm0000gn/T/tmp58b5bb1b.tmp/monotouch.dll.7.s:25651:branch out of range
Comment 2 Zoltan Varga 2012-09-27 14:08:54 UTC
How can I reproduce this ?
Comment 3 Luigi Saggese 2012-09-27 14:51:18 UTC
In my case happen all time when it's flagged LLVM and supported architecture ARMV7.
Comment 4 Luigi Saggese 2012-09-28 10:44:09 UTC
any news?
Comment 5 Rolf Bjarne Kvinge [MSFT] 2012-09-28 19:42:14 UTC
Luigi, do you get the same behavior if you create a new project from a template and enable LLVM for that project?
Comment 6 Luigi Saggese 2012-10-01 04:34:01 UTC
Created attachment 2660 [details]
Test Project
Comment 7 Luigi Saggese 2012-10-01 04:34:25 UTC
Created attachment 2661 [details]
Verbose Output Test Project
Comment 8 Luigi Saggese 2012-10-01 04:35:14 UTC
I have same problem with test project. I have attached Test project and verbose output. Let me know.
Comment 9 Zoltan Varga 2012-10-01 04:40:22 UTC
The test project has no source files.
Comment 10 Luigi Saggese 2012-10-01 04:46:44 UTC
sorry. i have attached right one :-)
Comment 11 Luigi Saggese 2012-10-01 04:48:37 UTC
Created attachment 2662 [details]
Right Test Project
Comment 12 Zoltan Varga 2012-10-01 07:21:27 UTC
I can reproduce this now, it happens when sgen is enabled, and linking is turned off. The .s file generated by llvm becomes so huge that it causes a linking problem.
As a workaround, you can set the linker behavior to 'link sdk assemblies only'. This is the default, and without it, the resulting application binary will be huge.
Comment 13 Rolf Bjarne Kvinge [MSFT] 2012-10-22 07:52:35 UTC

*** This bug has been marked as a duplicate of bug 1102 ***