Bug 749 - Can't load custom cursor from resx
Summary: Can't load custom cursor from resx
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: System (show other bugs)
Version: 2.10.x
Hardware: PC All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-09-11 13:56 UTC by Thomas Goldstein
Modified: 2011-09-11 17:26 UTC (History)
1 user (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Modified the test case from https://bugzilla.novell.com/show_bug.cgi?id=386607 to load the cursor from resx (30.06 KB, application/x-zip-compressed)
2011-09-11 13:56 UTC, Thomas Goldstein
Details

Description Thomas Goldstein 2011-09-11 13:56:37 UTC
Created attachment 323 [details]
Modified the test case from https://bugzilla.novell.com/show_bug.cgi?id=386607 to load the cursor from resx

If I add a cur file into the project, and set it as embedded resource, then Mono manages to load the cursor.

Like this:

this.Cursor = new Cursor(GetType(), "hand.cur");

However, if I try to load the cursor from a resx file, like this:

var resources = new ComponentResourceManager(typeof(Properties.Resources));
this.Cursor = resources.GetObject("hand") as Cursor;

Then it doesn't work.
On Mono on Windows, the cursor is no longer visible. On Mono on Linux, the cursor shown is the default one.

Note that loading images from resx works fine.
Comment 1 Thomas Goldstein 2011-09-11 17:26:42 UTC
Hmm, I listed this as a WinForms bug, but I think it's more likely that it's a System bug instead, as the bug probably comes from ComponentResourceManager or ResourceManager. Changing component to System.

Note You need to log in before you can comment on or make changes to this bug.