Bug 7467 - DefaultNonPersistentConnectionLimit is to low
Summary: DefaultNonPersistentConnectionLimit is to low
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 4.2.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Marek Habersack
URL:
Depends on:
Blocks:
 
Reported: 2012-09-26 07:25 UTC by Rodja Trappe
Modified: 2016-09-14 09:21 UTC (History)
3 users (show)

See Also:
Tags: XATriaged
Is this bug a regression?: ---
Last known good build:


Attachments

Description Rodja Trappe 2012-09-26 07:25:54 UTC
The DefaultNonPersistentConnectionLimit for MonoDroid seems to be 2. This is way to low for most Apps out there. It can take a few hours until a developer figures out where the problem is. I suggest to increase it to 10 like on MonoTouch:


-----8<----

#if MONOTOUCH
		public const int DefaultPersistentConnectionLimit = 10;
#else
		public const int DefaultPersistentConnectionLimit = 2;
#endif

------>8--- https://github.com/mono/mono/blob/master/mcs/class/System/System.Net/ServicePointManager.cs#L131
Comment 2 Atsushi Eno 2016-09-14 06:51:20 UTC
@grendel: do you think we should also change this too? Changing the number on the code is easy.
Comment 3 Marek Habersack 2016-09-14 09:21:37 UTC
Change made to mono in:

  master, commit d06354174070d01394f5e75ffcfc9c1110a1e7db
  mono-4.8.0-branch, commit 482ab094eb932f0655a710261267f3a1d6133678

The latter will make it into Xamarin.Android once it starts tracking Mono 4.8

Note You need to log in before you can comment on or make changes to this bug.