Bug 7398 - MonoTouch.Dialog EntryElement does not show entered characters
Summary: MonoTouch.Dialog EntryElement does not show entered characters
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: 5.4.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-09-22 11:17 UTC by frederic torres
Modified: 2013-12-05 18:34 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description frederic torres 2012-09-22 11:17:44 UTC
After installing 5.4.0 or 5.4.1, The EntryElement does not show the text entered.
My code did not change.
Reverting back to 5.2 ame then work.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-09-24 04:57:22 UTC
Isn't this the same as bug #7116? In any case we'll need a test case to try it ourselves.
Comment 2 Sebastien Pouliot 2012-09-24 10:36:24 UTC
It could also be related to bug #4736 and other ones (I don't recall the numbers).

A "short-lived" change that allowed tracking updates was reverted since it introduced some regressions.
Comment 3 Rodrigo 2013-08-01 01:02:08 UTC
I'm having the same problem in version Xamarin Studio 4.0.1 and iOS 6.4.1.1
Comment 4 m 2013-08-07 05:01:11 UTC
I'm also seeing this bug (iOS 6.1 and 6.0 simulator + Xamarin Studio 4.0.1).
Comment 5 Chris 2013-08-20 07:12:26 UTC
I've go the same problem since I updated to Xamarin iOS 6.4. It appears that the frame of the entryelement is wrong. For example, I've got X=25, Y=20.5, W=275, H=0.

I've fixed it temporary by giving the entryelement an fixed frame (Element.cs, around line 1555).
Comment 6 Chris 2013-08-20 07:14:15 UTC
Btw, the frame is only wrong after a few times the root element appears on screen.
Comment 7 PJ 2013-11-19 17:04:09 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 8 PJ 2013-12-05 18:34:10 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.