This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 7278 - CoreLocation not working with MonoMac
Summary: CoreLocation not working with MonoMac
Status: RESOLVED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Library (Xamarin.Mac.dll) (show other bugs)
Version: Master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: 2.4.0 (C6)
Assignee: Oleg Demchenko
URL:
Depends on:
Blocks:
 
Reported: 2012-09-18 15:38 UTC by Joel Martinez
Modified: 2015-05-26 12:09 UTC (History)
4 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Joel Martinez 2012-09-18 15:38:28 UTC
It would seem that core location is not working for some reason. I'm using the following sample: 
https://github.com/mono/monomac/tree/master/samples/WhereIsMyMac

and the .UpdatedLocation event is never raised. I posted about the issue on StackOverflow, and the issue was verified by at least one other person:
http://stackoverflow.com/questions/12322691/corelocation-not-working-with-monomac

I have verified that the application has location enabled in the privacy settings. I am on the latest version of the OS (Mountain Lion).
Comment 1 Timothy Risi 2015-02-12 20:55:37 UTC
Confirmed that UpdatedLocation is not being called and the UI is never updating after lauching.
Comment 2 Chris Hamons 2015-02-13 10:55:06 UTC
I bet this is another of those c# event are wrong due to stomping or such.

If you replace the events with a delegate instance, does it work?
Comment 3 Chris Hamons 2015-02-13 10:56:08 UTC
Oh, and apologies Joel on the crazy long delay in response. This bug was misfiled and lost until now. We're working on clearing up our backlog of bug. We're working to make sure it doesn't happen again in the future.
Comment 4 Timothy Risi 2015-02-18 19:34:11 UTC
It looks like the issue here is that the UpdatedLocation method was deprecated back in 10.6.  There's a LocationsUpdated method now that should be what's needed instead (I tried adding it to the sample and it was being being called repeatedly while UpdatedLocation was not).
Comment 5 Timothy Risi 2015-02-19 16:55:18 UTC
Oleg,

The sample needs to be updated since it's not working per my comment above (#4)
Comment 6 Oleg Demchenko 2015-05-26 12:09:58 UTC
Fixed in mac-samples/master: 51487f66ccefa5f9ff9c0f685559564f87f17607

Note You need to log in before you can comment on or make changes to this bug.