Bug 7174 - MonoTouch should build PCL projects against the MonoTouch assemblies
Summary: MonoTouch should build PCL projects against the MonoTouch assemblies
Status: RESOLVED DUPLICATE of bug 6649
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-09-14 06:27 UTC by Stuart Lodge
Modified: 2012-09-14 10:49 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 6649

Description Stuart Lodge 2012-09-14 06:27:47 UTC
Can we get the targetframework switching described in http://stackoverflow.com/questions/12041290/monodevelop-is-it-possible-to-switch-pcls-compiler/12062589#12062589 automated at build time using MonoDevelop?

I realise this comment in the StackOverflow answer says "this is fixed in Mono 2.12" but I'm not sure this includes the tool support. (Sorry if I've completely mis-described this problem!)

Linked to
- https://bugzilla.xamarin.com/show_bug.cgi?id=5329
- http://slodge.blogspot.co.uk/2012/09/a-helper-on-getting-monotouch-building.html

Thanks

Stuart
Comment 1 Mikayla Hutchinson [MSFT] 2012-09-14 10:49:03 UTC
It was fixed in https://github.com/mono/mono/commit/f415e91c696620a9f69fc1fa7017a66a9a25ee3d

*** This bug has been marked as a duplicate of bug 6649 ***