Bug 7003 - mdtool sometimes hangs
Summary: mdtool sometimes hangs
Status: RESOLVED DUPLICATE of bug 8566
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General (show other bugs)
Version: Trunk
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-09-07 19:33 UTC by Mikayla Hutchinson [MSFT]
Modified: 2013-05-20 12:56 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 8566

Description Mikayla Hutchinson [MSFT] 2012-09-07 19:33:17 UTC
mdtool sometimes hangs after a build in a busy wait, chewing up CPU. From the gdb backtrace it looks like it might be a runtime bug?

Thread 5 (process 69889):
#0  0x95a8622f in fegetenv ()
#1  0x98defac3 in time ()
#2  0x001d7c34 in _wapi_handle_ref (handle=0x819) at handles.c:1035
#3  0x001d9f10 in _wapi_handle_type [inlined] () at :282
#4  0x001d9f10 in _wapi_handle_trylock_handle [inlined] () at :284
#5  0x001d9f10 in _wapi_handle_count_signalled_handles (numhandles=2, handles=0x477ce0, waitall=0, retcount=0xb042cb4c, lowest=0xb042cb48) at handles-private.h:1432
#6  0x001ec583 in test_and_own (numobjects=2, handles=0x477ce0, waitall=0, count=0xb042cb4c, lowest=0xb042cb48) at wait.c:496
#7  0x001ecf3f in WaitForMultipleObjectsEx (numobjects=2, handles=0x477ce0, waitall=0, timeout=4294967295, alertable=1) at wait.c:658
#8  0x001bbef3 in ves_icall_System_Threading_WaitHandle_WaitAny_internal (mono_handles=0x9077828, ms=-1, exitContext=0) at threads.c:1616
#9 0x5c5514c in  (wrapper managed-to-native) System.Threading.WaitHandle:WaitAny_internal (System.Threading.WaitHandle[],int,bool) + 0x34 (0x5c55118 0x5c55186) [0x506e00 - mdtool.exe]
#10 0x5c54e74 in  System.Threading.WaitHandle:WaitAny (System.Threading.WaitHandle[],System.TimeSpan,bool) + 0x104 (0x5c54d70 0x5c54ed0) [0x506e00 - mdtool.exe]
#11 0x5c547b8 in  System.Threading.RegisteredWaitHandle:Wait (object) + 0xa8 (0x5c54710 0x5c54a39) [0x506e00 - mdtool.exe]
#12 0x556cad in  (wrapper runtime-invoke) <Module>:runtime_invoke_void__this___object (object,intptr,intptr,intptr) + 0x45 (0x556c68 0x556cf6) [0x506e00 - mdtool.exe]
#13 0x0000ecf4 in mono_jit_runtime_invoke (method=0x20263b4, obj=0x867a150, params=0xb042ce90, exc=0xb042ce98) at mini.c:5791
#14 0x00184354 in mono_runtime_invoke (method=0x20263b4, obj=0x867a150, params=0xb042ce90, exc=0xb042ce98) at object.c:2755
#15 0x0018462f in mono_runtime_delegate_invoke (delegate=0x867a150, params=0xb042ce90, exc=0xb042ce98) at object.c:3420
#16 0x001b83bf in async_invoke_thread (data=0x906ea00) at threadpool.c:626
#17 0x001bd8ec in start_wrapper (data=0x1b253c0) at threads.c:784
#18 0x001efa8a in thread_start_routine (args=0x104851c) at wthreads.c:287
#19 0x002171d4 in GC_start_routine (arg=0x500660) at pthread_support.c:1468
#20 0x98d99557 in _pthread_start ()
#21 0x98d83cee in thread_start ()

Thread 4 (process 69889):
#0  0x916ee9ae in kevent ()
#1  0x96735cc5 in _dispatch_mgr_invoke ()
#2  0x967357fd in _dispatch_mgr_thread ()

Thread 3 (process 69889):
#0  0x916eb80e in semaphore_wait_trap ()
#1  0x001f7eba in mono_sem_wait (sem=0x2c7df0, alertable=1) at mono-semaphore.c:115
#2  0x0012a142 in finalizer_thread (unused=0x0) at gc.c:1066
#3  0x001bd8ec in start_wrapper (data=0x631660) at threads.c:784
#4  0x001efa8a in thread_start_routine (args=0x10481b8) at wthreads.c:287
#5  0x002171d4 in GC_start_routine (arg=0x500f60) at pthread_support.c:1468
#6  0x98d99557 in _pthread_start ()
#7  0x98d83cee in thread_start ()

Thread 2 (process 69889):
#0  0x916eb7d2 in mach_msg_trap ()
#1  0x916eacb0 in mach_msg ()
#2  0x000ee0da in mach_exception_thread (arg=0x0) at mini-darwin.c:129
#3  0x002171d4 in GC_start_routine (arg=0x500f60) at pthread_support.c:1468
#4  0x98d99557 in _pthread_start ()
#5  0x98d83cee in thread_start ()

Thread 1 (process 69889):
#0  0x916ed8e2 in __psynch_cvwait ()
#1  0x98d9e220 in _pthread_cond_wait ()
#2  0x98e240ad in pthread_cond_wait$UNIX2003 ()
#3  0x001da4bf in _wapi_handle_timedwait_signal_handle (handle=0x800, timeout=0x0, alertable=1, poll=0) at handles.c:1655
#4  0x001da592 in _wapi_handle_wait_signal (poll=0) at handles.c:1584
#5  0x001ed281 in WaitForMultipleObjectsEx (numobjects=2, handles=0xbffff41c, waitall=1, timeout=4294967295, alertable=1) at wait.c:722
#6  0x001bc5d8 in wait_for_tids (wait=0xbffff41c, timeout=<value temporarily unavailable, due to optimizations>) at threads.c:2748
#7  0x001bf678 in mono_thread_manage () at threads.c:3048
#8  0x00074652 in mono_main (argc=5, argv=0xbffff968) at driver.c:1856
#9  0x00001fd6 in start ()
Comment 2 Alan McGovern 2012-09-17 09:32:55 UTC
Which version of mono are you running?
Comment 3 Mikayla Hutchinson [MSFT] 2012-09-17 14:59:55 UTC
2.10.9
Comment 4 Alan McGovern 2012-10-11 12:09:13 UTC
I have the exact same issue with the same stacktrace happening on the lion-2 bot.
Comment 5 Zoltan Varga 2012-10-11 12:42:37 UTC
Basically this command fails:

mono ../../../monodevelop/main/build/bin/mdtool.exe mac-bundle -p:Xamarin.Ide.Welcome.MacHost.csproj -c:Debug "FRC.app"

I tried running it in a loop locally, but no luck.
Comment 6 Mikayla Hutchinson [MSFT] 2013-05-20 12:56:42 UTC

*** This bug has been marked as a duplicate of bug 8566 ***