Bug 6649 - PCL targets are broken
Summary: PCL targets are broken
Status: RESOLVED FIXED
Alias: None
Product: Tools
Classification: Mono
Component: xbuild (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
: 7174 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-22 13:28 UTC by Mikayla Hutchinson [MSFT]
Modified: 2013-02-06 15:19 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mikayla Hutchinson [MSFT] 2012-08-22 13:28:09 UTC
The Microsoft.Portable.CSharp.targets file is broken - when building against MonoTouch, it does not use the correct compiler. See http://stackoverflow.com/a/12062589/116899
Comment 1 Jeffrey Stedfast 2012-08-22 13:45:28 UTC
Fixed in git master and mono-2-10 branch
Comment 2 Mikayla Hutchinson [MSFT] 2012-09-14 10:49:03 UTC
*** Bug 7174 has been marked as a duplicate of this bug. ***
Comment 3 Miguel de Icaza [MSFT] 2013-02-03 13:57:48 UTC
Jeff, the comment on the commit says the fix is wrong:

https://github.com/mono/mono/commit/f415e91c696620a9f69fc1fa7017a66a9a25ee3d

Could we make sure that this is fixed in Mono 2.10?

Duncan, can you get this fix in 2.10?
Comment 4 Jeffrey Stedfast 2013-02-06 15:15:13 UTC
The fix is correct for 2.10 (2.10 doesn't use the same compiler for all profiles).

The comment was saying that the fix was wrong for 3.0, but that's really more of a "it depends on which MonoTouch the user is using" and until we ship 3.0-based MonoTouch/Droids, using smcs is the right thing to do.
Comment 5 Jeffrey Stedfast 2013-02-06 15:19:22 UTC
n/m, we could still use the system's mono compiler, so we can yank the smcs stuff in master.