This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 6543 - Method that visible from Assembly Browser not found. (CS0584)
Summary: Method that visible from Assembly Browser not found. (CS0584)
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2012-08-15 14:21 UTC by folex
Modified: 2012-09-02 04:16 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Project with dll's. Zipped. (399.80 KB, application/zip)
2012-08-15 14:21 UTC, folex
Details

Description folex 2012-08-15 14:21:16 UTC
Created attachment 2354 [details]
Project with dll's. Zipped.

I'm trying to use AForge.Net frame work, but there is a strange thing happening.

When I try to apply filter through Bitmap Apply (Bitmap image) from AForge.Imaging.Filters.BaseFilter I'm getting the error:

Error CS0584: Internal compiler error: Method not found: 'AForge.Imaging.UnmanagedImage.CollectActivePixels'. (CS0584) (projectName)

Also, when I'm trying to use AForge.Imaging.Filters.Sepia or Invert, compiler couldn't find them:

Error CS0584: Internal compiler error: Could not import type AForge.Imaging.Filters.Sepia' fromAForge.Imaging, Version=2.2.4.0, Culture=neutral, PublicKeyToken=ba8ddea9676ca48b' (CS0584) (projectName)

The interesting thing is that AForge.Imaging.Filters.Grayscale found.

I've attached the whole project instead of copying code here.
Comment 1 Marek Safar 2012-09-02 04:16:38 UTC
You are missing `System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' assembly reference, included System.Drawing has different version number and is not signed.

The error message is better in Mono 2.11

Note You need to log in before you can comment on or make changes to this bug.