Bug 619 - LinearLayout.SetGravity( int ) should be GravityFlags?
Summary: LinearLayout.SetGravity( int ) should be GravityFlags?
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries (show other bugs)
Version: 1.0
Hardware: PC Windows
: --- minor
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-09-03 16:29 UTC by Roman Kalantari
Modified: 2014-03-28 11:56 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Roman Kalantari 2011-09-03 16:29:36 UTC
Seems like SetGravity on LinearLayout should take GravityFlags instead of an int, this is possibly because there is no getGravity so maybe it didnt get wired up correctly?
Comment 1 Roman Kalantari 2011-09-03 23:07:19 UTC
In addition seems like LayoutParams.Gravity should also be GravityFlags.
Comment 2 Atsushi Eno 2011-09-06 04:33:02 UTC
This will be fixed in the next release. Thanks!
Comment 3 Udham Singh 2014-03-28 11:56:52 UTC
I have checked this issue on following builds:

Windows 8.1
Xamarin Studio : 4.2.3 (build 60)
Xamarin.Android : 4.13.0 (Business Edition)

Screencast: http://screencast.com/t/hblUupYcl

This issue is working fine. Hence, I am closing this issue.