Bug 61206 (vs-564610) - code completion is broken
Summary: code completion is broken
Status: RESOLVED FIXED
Alias: vs-564610
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: 15.6
Assignee: Mike Krüger
URL:
: 61205 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-02 13:35 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2018-03-29 18:12 UTC (History)
5 users (show)

Tags: vs-sync
Is this bug a regression?: Yes
Last known good build: Version 7.2.2 (build 11)


Attachments
Screenshot (69.68 KB, image/png)
2018-02-02 13:35 UTC, Rolf Bjarne Kvinge [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rolf Bjarne Kvinge [MSFT] 2018-02-02 13:35:24 UTC
Repro:

* Create iOS project from a template
* Add the following code at the end of one of the code files:

    public class TestUIApplicationDelegate : Foundation.NSObject, UIKit.IUIApplicationDelegate
    {
    	override Did[cursor]
    }

this should show DidEnterBackground as an option, but it does not (see attached screenshot).

-----------------

Visual Studio Community 2017 for Mac (Preview)
Version 7.4 Preview (7.4 build 839)
Installation UUID: 3de793cc-1bea-4b7e-9e90-bb6747c5ca7e
Runtime:
	Mono 5.8.0.0 (2017-10/8a2a0628624) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 508000000

NuGet
Version: 4.3.1.4445

.NET Core
Runtime: /usr/local/share/dotnet/dotnet
Runtime Version: 2.0.0
SDK: /usr/local/share/dotnet/sdk/2.0.0/Sdks
SDK Version: 2.0.0
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.8.0/lib/mono/msbuild/15.0/bin/Sdks

Xamarin.Profiler
Version: 1.5.5
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

Apple Developer Tools
Xcode 9.2 (13772)
Build 9C40b

Xamarin.Mac
Version: 4.3.0.42 (Visual Studio Community)

Xamarin.iOS
Version: 11.9.0.42 (Visual Studio Community)
Hash: ede52142
Branch: linker-improve-isdirectbinding
Build date: 2018-01-12 07:46:18+0100

Xamarin.Android
Version: 7.0.99.113 (Visual Studio Community)
Android SDK: Not found

Xamarin Inspector
Version: 1.4.0-beta1+69
Hash: 4012b4e
Branch: master
Build date: Thu, 07 Dec 2017 16:20:26 GMT
Client compatibility: 1

Build Information
Release ID: 704000839
Git revision: 82eabac6f9ebeaa9c0f3143baa8037c26c6c00fc
Build date: 2018-01-05 22:22:29-05
Xamarin addins: b2cfc17e56386f2c360aaa8b02404b900d6be8c1
Build lane: monodevelop-lion-d15-6

Operating System
Mac OS X 10.12.6
Darwin 16.7.0 Darwin Kernel Version 16.7.0
    Thu Jan 11 22:59:40 PST 2018
    root:xnu-3789.73.8~1/RELEASE_X86_64 x86_64
Comment 1 Rolf Bjarne Kvinge [MSFT] 2018-02-02 13:35:40 UTC
Created attachment 26150 [details]
Screenshot
Comment 2 Rolf Bjarne Kvinge [MSFT] 2018-02-02 13:36:39 UTC
This is a regression, this worked at some point (and it's not the first time it's regressed either).
Comment 3 Rolf Bjarne Kvinge [MSFT] 2018-02-02 13:37:23 UTC
*** Bug 61205 has been marked as a duplicate of this bug. ***
Comment 5 John Miller [MSFT] 2018-02-09 14:06:48 UTC
I am able to reproduce with 7.4 and 7.5 (build 250) of VSMac. Marking CONFIRMED.
Comment 6 John Miller [MSFT] 2018-02-09 14:10:03 UTC
## Regression Check

7.2.2.11: GOOD
7.3: BAD
7.4: BAD
7.5.0.250: BAD

This seems to be a regression from 7.2.2 -> 7.3