Bug 61098 - TargetFrameworkVersion is set inccorectly
Summary: TargetFrameworkVersion is set inccorectly
Status: RESOLVED DUPLICATE of bug 60995
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Templates (show other bugs)
Version: 4.8.0 (15.5)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Pierce Boggan [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-12-14 13:20 UTC by stephen.machwirth
Modified: 2017-12-14 21:47 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Errormessage (18.77 KB, image/png)
2017-12-14 13:20 UTC, stephen.machwirth
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 60995

Description stephen.machwirth 2017-12-14 13:20:31 UTC
Created attachment 26005 [details]
Errormessage

When creating a Xamarin.Forms .NET Standard template the error message, shown in the attachment is shown. And there are no projects loaded in the solution. After that you can import them one by one by adding the .csproj files. However in case of the android file this is not the case and the error is shown like in the attachment. 

Apparently when the template is generated it'll add the following line in the android csproj file:
<TargetFrameworkVersion>"v8.0"</TargetFrameworkVersion>
The solution then is to change it to:
<TargetFrameworkVersion>v8.0</TargetFrameworkVersion>
Without the quotes and after that, everything works fine again!
Comment 1 Pierce Boggan [MSFT] 2017-12-14 21:47:36 UTC

*** This bug has been marked as a duplicate of bug 60995 ***