Bug 60850 - [Android] ViewCell containing View with TapRecognizer shows ContextActions on every tap
Summary: [Android] ViewCell containing View with TapRecognizer shows ContextActions on...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android (show other bugs)
Version: 2.5.0
Hardware: PC Windows
: Normal critical
Target Milestone: ---
Assignee: Bugzilla
URL:
: 60959 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-11-24 12:54 UTC by Matthias
Modified: 2018-01-04 22:14 UTC (History)
8 users (show)

Tags: listview, tapgesture, contextaction, ac fr
Is this bug a regression?: ---
Last known good build:


Attachments
repro (50.25 KB, application/x-zip-compressed)
2017-11-24 12:54 UTC, Matthias
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Matthias 2017-11-24 12:54:58 UTC
Created attachment 25827 [details]
repro

# Summary

A ViewCell containing a View with a TapRecognizer will show its ContextActions on every tap, instead of the long-press that is specific for android. Removing the TapRecognizer from the View resolves the behavior.

The context actions on Android should only be shown when there was a long press, hence this is a bug.

# Reproduction

The attached solution contains a single Android project with X.F backend. Running the project will display a page with a ListView, when an item is tapped, its context action "Action" will show up on top of the navigation bar.

# Versions

2.5.0.91635 BAD
Comment 1 Paul DiPietro [MSFT] 2017-12-03 15:05:19 UTC
*** Bug 60959 has been marked as a duplicate of this bug. ***
Comment 2 mina 2017-12-05 08:37:26 UTC
this very urgent issue why no one takes care of it
Comment 3 Matthias 2017-12-12 09:54:33 UTC
This is now tracked on GitHub: https://github.com/xamarin/Xamarin.Forms/issues/1331
Comment 4 mina 2017-12-12 13:00:27 UTC
how you mark this issue like RESOLVED FIXED , the issue not fixed yet
Comment 5 Rui Marinho 2018-01-03 15:19:55 UTC
Should be fixed on 2.6.0-pre1
Comment 6 Samantha Houts [MSFT] 2018-01-04 19:03:31 UTC
https://github.com/xamarin/Xamarin.Forms/pull/1441