Bug 60781 (vs-557313) - [Asset Editor] Import button should let you import multiple .imageset
Summary: [Asset Editor] Import button should let you import multiple .imageset
Status: RESOLVED FIXED
Alias: vs-557313
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: Trunk
Hardware: PC Mac OS
: Low enhancement
Target Milestone: 15.7
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2017-11-20 22:39 UTC by Vincent Dondain [MSFT]
Modified: 2018-02-23 18:28 UTC (History)
3 users (show)

Tags: vs-sync
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Vincent Dondain [MSFT] 2017-11-20 22:39:03 UTC
I wanted to explain how to move all assets from an iOS library project's asset catalog to an iOS project with an existing asset catalog (and assets inside it) but it turns out the import button has some limitation.

1. It doesn't seem possible to select multiple .imageset (inside a .xcassets). You can only import them 1 by 1 which is not ideal if you need to import 600 images sets.

2. It's possible to import the .imageset itself but that seems to mess-up the hierarchy (an xcasset inside an xcasset). The import should not try to include the the .xcasset folder but only its content.

Steps to repro:

- Create an iOS project.
- Create 3 image sets (open asset editor, right click the left section, select new image set and add random images).
- Create a new iOS project, open the asset editor, right click the left section and select import.

Expected behavior:

- Select multiple .imageset or when selecting a .xcasset it only imports the .imageset inside it.

Version information: https://gist.github.com/VincentDondain/6002340cf70279cdf93d086ae67d5220
Comment 1 Jeffrey Stedfast 2018-01-29 16:20:17 UTC
PR: https://github.com/xamarin/md-addins/pull/2840