Bug 60780 - [Xamarin.Android] method-to-ir.c:13326, condition `ins->opcode >= MONO_CEE_LAST' not met
Summary: [Xamarin.Android] method-to-ir.c:13326, condition `ins->opcode >= MONO_CEE_LA...
Status: RESOLVED DUPLICATE of bug 60625
Alias: None
Product: Runtime
Classification: Mono
Component: JIT (show other bugs)
Version: master
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2017-11-20 21:48 UTC by Marek Habersack
Modified: 2017-11-21 17:49 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
native crash stack trace (6.11 KB, text/x-log)
2017-11-20 21:48 UTC, Marek Habersack
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 60625

Description Marek Habersack 2017-11-20 21:48:45 UTC
Created attachment 25770 [details]
native crash stack trace

This is similar to https://bugzilla.xamarin.com/show_bug.cgi?id=60625 but it still happens with both mono/2017-10 and mono/master and XA/master. The crash happens while the app is loading on device (it's an xUnit runner WIP), see attachment. The device is Google Pixel 2 XL running Android 8.1 Beta.
Comment 2 Zoltan Varga 2017-11-21 01:01:47 UTC
Can I get the repo ? Also, does it happen on a simulator ?
Comment 3 Marek Habersack 2017-11-21 11:08:07 UTC
I wasn't able to repro this in the emulator (at least not x86 and there are no armv8 system images for API27)
Comment 4 Marek Habersack 2017-11-21 17:49:50 UTC
Bumping mono was ineffective, turns out, because XA build process reset the submodule to its original commit which caused me to run the test with old runtime thinking that it was the new one. Therefore, no bug exists - it got fixed in https://bugzilla.xamarin.com/show_bug.cgi?id=60625

*** This bug has been marked as a duplicate of bug 60625 ***