Bug 60780 - [Xamarin.Android] method-to-ir.c:13326, condition `ins->opcode >= MONO_CEE_LAST' not met
Summary: [Xamarin.Android] method-to-ir.c:13326, condition `ins->opcode >= MONO_CEE_LA...
Status: RESOLVED DUPLICATE of bug 60625
Alias: None
Product: Runtime
Classification: Mono
Component: JIT (show other bugs)
Version: master
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2017-11-20 21:48 UTC by Marek Habersack
Modified: 2017-11-21 17:49 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
native crash stack trace (6.11 KB, text/x-log)
2017-11-20 21:48 UTC, Marek Habersack
Details

Description Marek Habersack 2017-11-20 21:48:45 UTC
Created attachment 25770 [details]
native crash stack trace

This is similar to https://bugzilla.xamarin.com/show_bug.cgi?id=60625 but it still happens with both mono/2017-10 and mono/master and XA/master. The crash happens while the app is loading on device (it's an xUnit runner WIP), see attachment. The device is Google Pixel 2 XL running Android 8.1 Beta.
Comment 2 Zoltan Varga 2017-11-21 01:01:47 UTC
Can I get the repo ? Also, does it happen on a simulator ?
Comment 3 Marek Habersack 2017-11-21 11:08:07 UTC
I wasn't able to repro this in the emulator (at least not x86 and there are no armv8 system images for API27)
Comment 4 Marek Habersack 2017-11-21 17:49:50 UTC
Bumping mono was ineffective, turns out, because XA build process reset the submodule to its original commit which caused me to run the test with old runtime thinking that it was the new one. Therefore, no bug exists - it got fixed in https://bugzilla.xamarin.com/show_bug.cgi?id=60625

*** This bug has been marked as a duplicate of bug 60625 ***

Note You need to log in before you can comment on or make changes to this bug.