Bug 60722 (vs-549723) - Cannot select iOS device - hit area overlap is wrong.
Summary: Cannot select iOS device - hit area overlap is wrong.
Status: RESOLVED FIXED
Alias: vs-549723
Product: Xamarin Studio
Classification: Desktop
Component: Shell (show other bugs)
Version: 7.2 (d15-4)
Hardware: PC Mac OS
: Normal normal
Target Milestone: 15.6
Assignee: Vsevolod Kukol
URL:
Depends on:
Blocks:
 
Reported: 2017-11-16 15:55 UTC by David Ortinau [MSFT]
Modified: 2018-03-05 07:46 UTC (History)
6 users (show)

Tags: vs-sync
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description David Ortinau [MSFT] 2017-11-16 15:55:42 UTC
https://www.screencast.com/t/5DkySgqglR

I have my IDE slightly smaller than the screen and it bunches the config and device dropdowns tighter. In this state I cannot select the devices and instead I get the build config list.

If I widen my window, it's all available, but I really didn't have it that small.
Comment 1 Greg Munn 2017-11-16 17:39:26 UTC
FWIW, I am unable to reproduce this

https://screencast.com/t/wu9JxYPT46
Comment 2 David Ortinau [MSFT] 2018-01-08 16:48:03 UTC
Still happens on 7.3.3. This is a clean install.

Env details: https://gist.github.com/davidortinau/3f72a5caef96f7b87d8b1d4b8c508ff7

As you can see the debug string is wide enough to overlay the device selection. This is actually me clicking on what should be the device. 

https://www.dropbox.com/s/3nmfwz2c6tkxp3s/Screenshot%202018-01-08%2010.45.09.png?dl=0

This is my desktop to show the size/proportions of the IDE on screen.

https://www.dropbox.com/s/7s0qkngfk4dgetl/Screenshot%202018-01-08%2010.46.16.png?dl=0

My screen preferences: 

https://www.dropbox.com/s/45qy3dkjgeuanyu/Screenshot%202018-01-08%2010.46.52.png?dl=0
Comment 3 xamarin-release-manager 2018-01-12 12:05:30 UTC
Fixed in version 7.5.0.160 (master)

Author: Vsevolod Kukol
Commit: 1c0c1919a8a78e6d6af13efe658e6f11bdea8300 (mono/monodevelop)
Comment 4 Marcos Cobeña Morián 2018-03-05 07:27:55 UTC
Hi guys,

I was filling a new bug and found this one. Let me attach a GIF where I reproduce what David says, although you already fixed this out.

Would you know any ETA for 7.5.x becoming stable?

Thanks in advance for all your work,

—Marcos
Comment 5 Marcos Cobeña Morián 2018-03-05 07:31:15 UTC
https://drive.google.com/open?id=14CkeASikqE374msncUBWfg13P2nS1bEw
Comment 6 Vsevolod Kukol 2018-03-05 07:46:40 UTC
Hi, this is fixed in 7.4 too, which will hit stable this week (you can try the beta channel already). 7.5 will be released around May. Thanks!