Bug 60625 - local-propagation.c:562, condition `ins->opcode > MONO_CEE_LAST' not met
Summary: local-propagation.c:562, condition `ins->opcode > MONO_CEE_LAST' not met
Status: VERIFIED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: JIT (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: 15.6
Assignee: Bugzilla
URL:
: 60780 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-11-10 21:47 UTC by Jerome Laban
Modified: 2017-12-26 09:33 UTC (History)
10 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Repro (7.97 KB, application/x-zip-compressed)
2017-11-10 21:47 UTC, Jerome Laban
Details
VS version (3.45 KB, text/plain)
2017-11-10 21:47 UTC, Jerome Laban
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jerome Laban 2017-11-10 21:47:08 UTC
Created attachment 25647 [details]
Repro

When running the attached sample, in JIT mode the following code:

        private void Test(string key)
        {
            unsafe
            {
                unchecked
                {
                    fixed (char* src = key)
                    {
                    }
                }
            }
        }

Fails with the following error:

* Assertion at /Users/builder/jenkins/workspace/xamarin-android/xamarin-android/external/mono/mono/mini/local-propagation.c:562, condition `ins->opcode > MONO_CEE_LAST' not met

This also fails AOT generation.

See attached details for repro.

This is also an issue in Xamarin.iOS.
Comment 1 Jerome Laban 2017-11-10 21:47:29 UTC
Created attachment 25648 [details]
VS version
Comment 2 Zoltan Varga 2017-11-15 22:47:42 UTC
This will fix it:
https://github.com/mono/mono/pull/6020
Comment 3 Zoltan Varga 2017-11-16 21:54:26 UTC
Fixed in mono master/2017-10 branches.
Comment 4 Marek Habersack 2017-11-21 17:49:50 UTC
*** Bug 60780 has been marked as a duplicate of this bug. ***
Comment 5 Sebastien Pouliot 2017-12-14 02:02:53 UTC
@Zoltan, the release branch is `d15-5-2017-06`, can you back-rot the fix there ? thanks!
Comment 6 Zoltan Varga 2017-12-14 02:51:16 UTC
https://github.com/mono/mono/pull/6242