Bug 60288 - Large Array Initializer Causes TypeLoadException
Summary: Large Array Initializer Causes TypeLoadException
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 5.0 (2017-02)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-20 14:18 UTC by Jonathan Chambers
Modified: 2017-10-26 13:50 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test Case (5.88 MB, text/plain)
2017-10-20 14:19 UTC, Jonathan Chambers
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jonathan Chambers 2017-10-20 14:18:48 UTC
Run the attached example. On .NET things run fine. On Mono there is TypeLoadException due to the array initializer becoming a value type larger than 1MB.
Comment 1 Jonathan Chambers 2017-10-20 14:19:18 UTC
Created attachment 25382 [details]
Test Case
Comment 2 Zoltan Varga 2017-10-23 19:55:20 UTC
https://github.com/mono/mono/pull/5844
Comment 3 Zoltan Varga 2017-10-26 13:50:35 UTC
Fixed by mono master 13a9fb6c7a51016306b80fa0bf41c8cacb424c38.