Bug 60225 - Coverage output is missing some types and methods
Summary: Coverage output is missing some types and methods
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Profiler (show other bugs)
Version: unspecified
Hardware: PC All
: Normal normal
Target Milestone: Future Cycle (TBD)
Assignee: Alex Rønne Petersen
URL:
Depends on:
Blocks:
 
Reported: 2017-10-17 09:51 UTC by Marek Safar
Modified: 2018-02-11 16:30 UTC (History)
4 users (show)

Tags: bugpool-archive
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Marek Safar 2017-10-17 09:51:59 UTC
When using code coverage with mscorlib

in `mcs/class/corlib` do `COVERAGE=1 make run-test`

the generated .xml output file is missing some entries

For example only 

System.Tuple 	 
System.Tuple`2
System.Tuple`3 	 
System.Tuple`8

remaining tuples are not used and are missing in the output
Comment 1 Ludovic Henry 2017-11-08 22:21:28 UTC
It's because we dump the uncovered methods on the covered classes, not the uncovered classes (https://github.com/mono/mono/blob/ceec5e9786dc9866409e4dd3523d4e1eb3f5af49/mono/profiler/coverage.c#L380)
Comment 2 Alex Rønne Petersen 2018-01-17 09:05:49 UTC
https://github.com/mono/mono/pull/6544