Bug 60158 - Xamarin causes Visual Studio to freeze when opening Xamarin.Forms sln
Summary: Xamarin causes Visual Studio to freeze when opening Xamarin.Forms sln
Status: RESOLVED DUPLICATE of bug 60080
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General (show other bugs)
Version: 4.7.0 (15.4)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-12 18:06 UTC by Jason Smith [MSFT]
Modified: 2017-10-17 03:18 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: 15.3

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 60080

Description Jason Smith [MSFT] 2017-10-12 18:06:03 UTC
Happens every time, with perfect reliability. The solution doesn't even finish loading before the hardlock. VS becomes completely unresponsive.

Xamarin: 4.7.10.22
X.A.: 8.0.0.33
X.I.: 11.2.0.8

Did not happen with the previous stable release.
Comment 1 Jason Smith [MSFT] 2017-10-12 18:25:41 UTC
Just realized I forgot to mention this happens with VS2015
Comment 2 Rafael Santos 2017-10-14 11:06:19 UTC
I have the same problem, any new on that ?
Comment 3 Eric Liu 2017-10-15 21:12:31 UTC
for me it's the 15.5-preview-1. There is a "hidden" crash reporting window or something "werfault.exe" and creating a 800MB dump file in the TEMP folder when I try to load Xamarin project. Sometimes loading without crash sometimes not. Just recently crashed 9 times, so I decided to unload every xamarin extensions + deleted ".vs" folder in my solution folder to clear the settings, closed vs, then reloaded every xamarin extensions, closed vs again and then the solution loaded without crash.
Comment 4 Jimmy [MSFT] 2017-10-17 03:18:30 UTC
This is the same issue as bug 60080 and all future updates on this issue will be provided in that report. 

The current workaround that people are reporting success with is to delete the .vs folder in your solution directory.

*** This bug has been marked as a duplicate of bug 60080 ***