Bug 60034 - iOS Marketing icon for iOS 11 not being added to ipa
Summary: iOS Marketing icon for iOS 11 not being added to ipa
Status: RESOLVED DUPLICATE of bug 59999
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: Trunk
Hardware: PC Windows
: Low normal
Target Milestone: Future Cycle (TBD)
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2017-10-07 05:51 UTC by Ian
Modified: 2017-10-09 05:33 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
No 1024 image (309.98 KB, image/png)
2017-10-07 05:51 UTC, Ian
Details

Description Ian 2017-10-07 05:51:58 UTC
Created attachment 25181 [details]
No 1024 image

In Visual Studio 2017

I add the new json into the content.json file for the new iOS 11 Marketing icon

    {
      "filename": "1024x1024.png",
      "size": "1024x1024",
      "scale": "1x",
      "idiom": "ios-marketing"
    }

Then I build to Release the app, with the .IPA requested to be built.

I then open the IPA file on the Mac build host, and browse the .app. THere is no 1024x1024.png file anywhere in the .app file. Of course, the Application Loader rejects the app.

I have verified that the 1024x1024.png has no Alpha/Transparency 

How can we get Visual Studio 2017 to include the Marketing Image into the .App ?

See screenshot
Comment 1 Ian 2017-10-07 19:27:20 UTC
VS for Mac doesn't add the image to the .ipa either. Here's screenshot of the Assets editor showing the 1024 Marketing image.

https://us.v-cdn.net/5019960/uploads/editor/3q/12swvrbtwhan.png
Comment 2 Ian 2017-10-07 20:15:26 UTC
SOLUTION:

In VS 2017 on Windows, if you bring over a project from VS for Mac "AND" use source control like VisualStudio.com, the Asset Catalog's new 1024.png file in there, but it not included in the .csproj. The solution is to right click the /Resources/<your asset catalog> and choose "Include in Project"

VS 2017 should check that all asset catalog files are in the .csproj, and if not through a build error
Comment 4 Mike Krüger 2017-10-09 05:33:50 UTC
Seems to be a duplicate of 59999 at least they are closely related.

*** This bug has been marked as a duplicate of bug 59999 ***

Note You need to log in before you can comment on or make changes to this bug.