Bug 60025 - [llvm][bitcode] System.Core test failure: [FAIL] EnumerableAsQueryableTest.SelectMany : System.ArgumentException : Destination array was not long enough. Check destIndex and length, and the array's lower bounds
Summary: [llvm][bitcode] System.Core test failure: [FAIL] EnumerableAsQueryableTest.Se...
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Mono runtime / AOT compiler (show other bugs)
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: 15.7
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2017-10-06 15:18 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2018-03-09 14:06 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rolf Bjarne Kvinge [MSFT] 2017-10-06 15:18:09 UTC
Repro:

* Run "make run-watchos-dev-System.Core CONFIG=Release" in xamarin-macios/tests

Result:

 [FAIL] EnumerableAsQueryableTest.SelectMany : System.ArgumentException : Destination array was not long enough. Check destIndex and length, and the array's lower bounds

This only happens on a watchOS device in release mode.

I can reproduce with master, d15-5 and d15-4. The test suite crashes before reaching this test in d15-3, which means it's most likely not a regression.

Complete build log: https://gist.github.com/rolfbjarne/1f8bf39425548dd22c37b2efc71aed7b
Complete test log: https://gist.github.com/rolfbjarne/a7ae57b5f72a71406640189baa0f468f
Comment 1 Rolf Bjarne Kvinge [MSFT] 2018-03-09 14:06:44 UTC
I can't reproduce anymore in d15-7.