Bug 60022 - Carousel in navigation page NavigationPage.SetHasNavigationBar(this, false) - iOS 11 issue
Summary: Carousel in navigation page NavigationPage.SetHasNavigationBar(this, false) -...
Status: RESOLVED DUPLICATE of bug 59741
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-06 14:06 UTC by William Watterson
Modified: 2017-10-06 14:16 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Carousel page issues - iOS10 vs iOS11 (1.54 MB, image/gif)
2017-10-06 14:06 UTC, William Watterson
Details

Description William Watterson 2017-10-06 14:06:49 UTC
Created attachment 25170 [details]
Carousel page issues - iOS10 vs iOS11

Hi, 

I am having an issue with a carousel page app built for iOS 11 (using XCode9).

Basically I have written a test Xamarin forms application to illustrate what my issues is (Forms version 2.4.0.282).  The main page is a navigation page.  When I push a carousel page onto the stack and set NavigationPage.SetHasNavigationBar(this, false); The carousel page moves down as well as across.  Please see the video attached.  

The video shows how it worked in iOS 10, and how it now works in iOS 11.    

The issue is that the whole page "lifts" when I swipe down as well as across.  Previously the carousel page only moved left or right when I swiped either left or right.  Another issue is that sometimes, the carousel page snaps to just below the status bar, rather than to the top of the screen - this is shown in the iOS 11 video too.

As a side note.. this is causing issues with a pull to refresh on a carousel page.  When it "snaps" to below the status bar, the pull to refresh is ignored.  If it is docked to the top of the screen, then the pull to refresh does work.  But at the moment I am more concerned about how it looks rather than pull to refresh.


I have tried previous versions of Xamarin.Forms and the issue persists.  

Please help.


Xamarin - 4.7.9.45
Xamarin.iOS and Xamarin.Mac SDK - 11.0.0.0
Xamarin.Forms - 2.4.0.282
Xcode Version - 9.0


Thanks,
William
Comment 1 Paul DiPietro [MSFT] 2017-10-06 14:16:34 UTC

*** This bug has been marked as a duplicate of bug 59741 ***

Note You need to log in before you can comment on or make changes to this bug.