Bug 60012 - App crashing when binding the int property to nullable double? data type bindable property.
Summary: App crashing when binding the int property to nullable double? data type bind...
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.4.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-06 10:52 UTC by karthikeyanv
Modified: 2017-11-06 21:35 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description karthikeyanv 2017-10-06 10:52:37 UTC
My App crashing when binding the CLR property int value to nullable double? data type bindable property.

public static readonly BindableProperty MinimumProperty =
            BindableProperty.Create("Minimum", typeof(double?), typeof(DataClass), null, BindingMode.Default, null,
                null);


public double? Minimum
{
    get { return (double?)GetValue(MinimumProperty); }
    set { SetValue(MinimumProperty, value); }
}
Comment 1 Paul DiPietro [MSFT] 2017-10-08 21:33:53 UTC
What is the error you're seeing? Can you please provide a reproduction and diagnostic info?
Comment 2 Paul DiPietro [MSFT] 2017-11-06 21:35:30 UTC
As we have not heard back in over a month we will be closing this issue. Please reopen with a reproduction project to aid investigation if the issue is still occurring as of the latest stable build of Forms. Thanks!