Bug 60008 - VS for Mac wont build if Proxifier is running
Summary: VS for Mac wont build if Proxifier is running
Status: NEEDINFO
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General (show other bugs)
Version: 7.1 (d15-3)
Hardware: Macintosh Mac OS
: Low normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-06 04:26 UTC by Cheyo E Jimenez
Modified: 2017-10-06 07:33 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Cheyo E Jimenez 2017-10-06 04:26:21 UTC
https://stackoverflow.com/questions/46597995/visual-studio-mac-doesnt-build

Can not build in Visual Studio Mac (Used to be Xamarin)

Nothing builds or cleans. Not even a console app. I am using version 7.1.5 on macOS 10.12.6.

I uninstalled and reinstall and still the same issue.

Error: Build failed. See the build log for details.

This is the error in the build log:

--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in /private/tmp/source-mono-d15-3/bockbuild-d15-3/profiles/mono-mac-xamarin/build-root/mono-x64/mcs/class/referencesource/mscorlib/system/runtime/exceptionservices/exceptionservicescommon.cs:151 
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x00037] in /private/tmp/source-mono-d15-3/bockbuild-d15-3/profiles/mono-mac-xamarin/build-root/mono-x64/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:187 
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00028] in /private/tmp/source-mono-d15-3/bockbuild-d15-3/profiles/mono-mac-xamarin/build-root/mono-x64/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:156 
  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00008] in /private/tmp/source-mono-d15-3/bockbuild-d15-3/profiles/mono-mac-xamarin/build-root/mono-x64/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:128 
  at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () [0x00000] in /private/tmp/source-mono-d15-3/bockbuild-d15-3/profiles/mono-mac-xamarin/build-root/mono-x64/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:535 
  at MonoDevelop.Projects.Project+<>c__DisplayClass142_1+<<RunMSBuildTarget>b__0>d.MoveNext () [0x00113] in /Users/builder/data/lanes/5123/7afedcae/source/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/Project.cs:1200 
--- End of stack trace from previous location where exception was thrown ---

This only happens when I am using Proxifier Version 2.21 http://www.proxifier.com/mac/
Comment 1 Mike Krüger 2017-10-06 07:12:11 UTC
I can't reproduce the issue - do I need to set up something in proxifier to reproduce ? 

https://screencast.com/t/cLQ66Vg7U8
Comment 2 Cheyo E Jimenez 2017-10-06 07:33:24 UTC
Yes. You need to add a proxy. 
http://www.proxifier.com/mac/documentation/v2/proxy.htm
My current set up is using a Socks 5 Proxy. 
Then you set that proxy as the default so all the traffic uses the proxy. 

Under DNS I have it set to:
Resolve hostnames through proxy

under Advance / Connections:

I have all the options checked:

Handle direct connections, 
infinite connection loop detection
Application run by other users in this computer
system processes

everything else is default.

You create a Socks 5 proxy similar to this tutorial: https://www.digitalocean.com/community/tutorials/how-to-route-web-traffic-securely-without-a-vpn-using-a-socks-tunnel

Note You need to log in before you can comment on or make changes to this bug.