Bug 60007 - Show help in execution target when deployment target is too high and no simulators show up
Summary: Show help in execution target when deployment target is too high and no simul...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: Trunk
Hardware: PC Mac OS
: Low enhancement
Target Milestone: 15.6
Assignee: Vincent Dondain [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-10-06 00:01 UTC by Vincent Dondain [MSFT]
Modified: 2017-10-17 21:59 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Vincent Dondain [MSFT] 2017-10-06 00:01:04 UTC
Often happens to me, I create a new project (currently iOS 11 because we always pick the max version), do some testing and change my Xcode to an older one (which doesn't support iOS 11) and I get confused because no simulators show up.

https://www.dropbox.com/s/gph4stqmd854tqj/Screenshot%202017-10-05%2019.53.18.png?dl=0

We should do the same this we do for device, show a greyed out section;

Simulator

Try to lower the 'Deployment Target' to see older simulators
Comment 1 Vincent Dondain [MSFT] 2017-10-10 17:56:42 UTC
https://github.com/xamarin/md-addins/pull/2577
Comment 2 xamarin-release-manager 2017-10-17 21:59:59 UTC
Fixed in version 7.4.0.341 (master)

Author: Vincent Dondain
Commit: 89189e5c488ae9fbbb4c65d5ea257a88a08a9879 (xamarin/md-addins)
Included in Commit: 318f13004b9dacbb53ce6fb3be1e3dead8103bf8 (mono/monodevelop)