Bug 60005 - [UWP] Crashes upon startup when compiled for the Windows Store.
Summary: [UWP] Crashes upon startup when compiled for the Windows Store.
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: unspecified
Hardware: PC Windows
: High major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-05 21:33 UTC by Brad Chase
Modified: 2017-10-17 09:12 UTC (History)
6 users (show)

Tags: fr, uwp, netnative
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Brad Chase 2017-10-05 21:33:26 UTC
UWP will crash upon startup due to the internal classes being culled out by .NET Native.  There are still some others that will crash like DisplayActionSheet.

Temporary work around is to add a blanket coverage for the entire assembly in each users rd file.
Comment 1 Brad Chase 2017-10-05 21:35:33 UTC
Linkback to PR:

https://github.com/xamarin/Xamarin.Forms/pull/1186
Comment 2 Rui Marinho 2017-10-16 18:32:22 UTC
Should be fixed on 2.4.0 service release 2