Bug 60003 - Missing iPhone X Launch Image in VSMac
Summary: Missing iPhone X Launch Image in VSMac
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: 15.6
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2017-10-05 21:11 UTC by Sebastian Kruse
Modified: 2018-01-29 15:40 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Sebastian Kruse 2017-10-05 21:11:10 UTC
Missing an option to add a iPhone X Launch Image (and new Icon Sizes related to Super Retina Displays?).
Comment 1 Vincent Dondain [MSFT] 2017-10-05 22:45:32 UTC
Hi,

Thanks for this bug report.

@3x resolutions have been around since the iPhone 6S: https://developer.apple.com/ios/human-interface-guidelines/icons-and-images/image-size-and-resolution/

So we're good with regard to the app icons since we do have @3x there.

Note: the "super" in "Super Retina Display" doesn't mean a change of resolution but the fact that it's an OLED display.

However you're right we are missing the iPhone X launch images (see https://www.dropbox.com/s/wqjt4ovfi6caete/Screenshot%202017-10-05%2018.30.13.png?dl=0).

Please not that this should be a "minor" issue given that it's recommended to use a LaunchScreen.storyboard (;
Comment 2 Sebastian Kruse 2017-10-06 08:37:16 UTC
The DPI-Value is a bit higher compared to the iPhone 6/6S/7/8 (Plus). That's why I thought it might be a higher resolution icon. 

And yes, it is a "minor" issue. I just had two projects that are based on LaunchImages. Maybe I should just change them to Storyboards, this way I would also gain the SplitView on iPads. But it would be nice if the option is added too. ;)
Comment 3 Jeffrey Stedfast 2017-10-06 19:44:07 UTC
PR: https://github.com/xamarin/md-addins/pull/2565
Comment 4 Mike Bluestein 2018-01-29 15:40:50 UTC
Appears this isn't fixed. I just had to hack the contents.json and csproj files manually to get it to work per https://forums.xamarin.com/discussion/103677/launcheimage-for-iphone-x (and it still doesn't render in the VS for Mac view, but it does work at runtime). Interestingly, using any name other than "1125_2436@2x.png" didn't work.