Bug 59992 - PackageReference doesn't support Version attribute, only Version subelement
Summary: PackageReference doesn't support Version attribute, only Version subelement
Status: CLOSED INVALID
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: .NET Core support (show other bugs)
Version: Trunk
Hardware: PC Mac OS
: High normal
Target Milestone: 15.5
Assignee: Matt Ward
URL:
Depends on:
Blocks:
 
Reported: 2017-10-05 17:25 UTC by Kirill Osenkov
Modified: 2017-10-05 17:40 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED INVALID

Description Kirill Osenkov 2017-10-05 17:25:40 UTC
In a non-SDK-style project (C# Console for example) add a 

<PackageReference Include="System.ValueTuple" Version="4.4.0" />

Expected:
should build

Actual:
Fails to build with:
The attribute "Version" in element <PackageReference> is unrecognized.

========

=== Visual Studio Community 2017 for Mac (Preview) ===

Version 7.2 Preview (7.2 build 634)
Installation UUID: f03e6a7b-36c5-4727-93d1-6cccf45d6632
Runtime:
    Mono 5.4.0.201 (2017-06/71277e78f6e) (64-bit)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 504000201

=== NuGet ===

Version: 4.3.1.4445

=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
Runtime Versions:
    2.0.0
    1.1.1
    1.0.4
SDK: /usr/local/share/dotnet/sdk/2.0.0/Sdks
SDK Versions:
    2.0.0
    1.0.1
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.4.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.6
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 8.3.3 (12175.1)
Build 8E3004b

=== Xamarin.iOS ===

Version: 11.2.0.8 (Visual Studio Community)
Hash: 9a9f0541
Branch: d15-4-xi
Build date: 2017-09-20 14:57:51-0400

=== Xamarin.Android ===

Version: 8.0.0.33 (Visual Studio Community)
Android SDK: /Users/kirill/Library/Developer/Xamarin/android-sdk-macosx
    Supported Android versions:
        6.0 (API level 23)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.5
SDK Build Tools Version: 25.0.3

Java SDK: /usr
java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin.Mac ===

Version: 3.8.0.49 (Visual Studio Community)

=== Xamarin Inspector ===

Version: 1.3.2
Hash: 461f09a
Branch: 1.3-release
Build date: Tue, 03 Oct 2017 18:26:57 GMT
Client compatibility: 1

=== Build Information ===

Release ID: 702000634
Git revision: cab57de4a7f8c07b8d910d14fff83942cd3f02bf
Build date: 2017-10-02 13:18:41-04
Xamarin addins: a8da992c78f7eb65b3cdb3f951c34a30337cab35
Build lane: monodevelop-lion-d15-4

=== Operating System ===

Mac OS X 10.12.5
Darwin 16.6.0 Darwin Kernel Version 16.6.0
    Fri Apr 14 16:21:16 PDT 2017
    root:xnu-3789.60.24~6/RELEASE_X86_64 x86_64
Comment 1 Kirill Osenkov 2017-10-05 17:40:15 UTC
I was using xbuild. This is not a bug.