Bug 59982 - Navigating to another page is not working inside ListView.
Summary: Navigating to another page is not working inside ListView.
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.4.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-05 13:17 UTC by Paul Anderson
Modified: 2017-10-10 10:21 UTC (History)
2 users (show)

See Also:
Tags: tapgesture, listview, ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample (817.27 KB, application/zip)
2017-10-05 13:17 UTC, Paul Anderson
Details

Description Paul Anderson 2017-10-05 13:17:26 UTC
Created attachment 25125 [details]
Sample

My main page contains Xamarin.Forms ListView and I have applied ItemTemplate to customise the cell. I have one Image and Label for each cell and added tap gesture to Image.My requirement is whenever the Image is tapped I want to navigated to a new page but I was unable to view the new page. While debugging I was unable to find the root cause since all things are goes fine. 

Run the attached sample and tap any one of the cell(image) and observe the response.I have handled page navigation on MyView.cs file.
Comment 1 Paul DiPietro [MSFT] 2017-10-05 15:42:08 UTC
I will set this as confirmed until further investigation can be made, but the tap gesture does not fire off.
Comment 2 Paul Anderson 2017-10-06 05:48:27 UTC
When Can I get the possible solutions for the reported issue?
Comment 3 Paul Anderson 2017-10-06 05:48:41 UTC
When Can I get the possible solutions for the reported issue?
Comment 4 Paul Anderson 2017-10-10 10:21:06 UTC
Any updates? We are at the end of our project completion and this issue stops us to deliver.

Note You need to log in before you can comment on or make changes to this bug.