Bug 59982 - Navigating to another page is not working inside ListView.
Summary: Navigating to another page is not working inside ListView.
Status: RESOLVED ANSWERED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.4.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-05 13:17 UTC by Paul Anderson
Modified: 2018-03-13 11:43 UTC (History)
4 users (show)

Tags: tapgesture, listview, ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample (817.27 KB, application/zip)
2017-10-05 13:17 UTC, Paul Anderson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Paul Anderson 2017-10-05 13:17:26 UTC
Created attachment 25125 [details]
Sample

My main page contains Xamarin.Forms ListView and I have applied ItemTemplate to customise the cell. I have one Image and Label for each cell and added tap gesture to Image.My requirement is whenever the Image is tapped I want to navigated to a new page but I was unable to view the new page. While debugging I was unable to find the root cause since all things are goes fine. 

Run the attached sample and tap any one of the cell(image) and observe the response.I have handled page navigation on MyView.cs file.
Comment 1 Paul DiPietro [MSFT] 2017-10-05 15:42:08 UTC
I will set this as confirmed until further investigation can be made, but the tap gesture does not fire off.
Comment 2 Paul Anderson 2017-10-06 05:48:27 UTC
When Can I get the possible solutions for the reported issue?
Comment 3 Paul Anderson 2017-10-06 05:48:41 UTC
When Can I get the possible solutions for the reported issue?
Comment 4 Paul Anderson 2017-10-10 10:21:06 UTC
Any updates? We are at the end of our project completion and this issue stops us to deliver.
Comment 5 Paul Anderson 2017-11-09 10:46:13 UTC
Our project delivery is delaying due to this issue? when it will be fixed? Could you please share the timeline?
Comment 6 Paul DiPietro [MSFT] 2017-12-04 16:20:23 UTC
Please do not change these statuses from confirmed to needinfo when the issue is confirmed. This has not been assigned for work and its status will be updated when that occurs. In the meantime we also welcome PRs with bug fixes from the community, and guidelines for how to contribute are available at https://github.com/xamarin/Xamarin.Forms/wiki/How-to-Contribute.
Comment 7 Paul Brenner 2018-03-12 19:37:51 UTC
See https://github.com/xamarin/Xamarin.Forms/issues/2082
Comment 8 Stephane Delcroix 2018-03-13 11:43:07 UTC
Please follow the issue on GitHub for updates. Thank you.