Bug 59980 - OnResume event fire twice in Xamarin.forms PCL
Summary: OnResume event fire twice in Xamarin.forms PCL
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-05 11:31 UTC by Parmendra
Modified: 2017-10-05 15:59 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Parmendra 2017-10-05 11:31:42 UTC
Steps to reproduce:

1. Create a Xamarin.forms PCL project.
2. Breakpoint in OnResume method.
3. Run Android application.
3. Press home button on device and restart app.

Actual result: OnResume method breakpoint hit twice.

EnvironmentInfo:

Microsoft Visual Studio Professional 2015
Version 14.0.24720.00 Update 1
Microsoft .NET Framework
Version 4.6.01055
Comment 1 Parmendra 2017-10-05 11:33:36 UTC
Version 14.0.24720.00 Update 1
Microsoft .NET Framework
Version 4.6.01055

Installed Version: Professional

Xamarin   4.0.0.1717 (1390b70)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   6.0.0.35 (d300845)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS   9.3.99.33 (ea30b32)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 2 Paul DiPietro [MSFT] 2017-10-05 15:59:51 UTC
I cannot reproduce this with 2.4.0 stable -- the breakpoint only hits once. Please reopen this with a reproduction project if this occurs for you as of the latest stable build. Thanks!