Bug 59978 - Failed to compile the generated registrar code. Please file a bug report at http://bugzilla.xamarin.com
Summary: Failed to compile the generated registrar code. Please file a bug report at h...
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: XI 11.4 (d15-5)
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-05 11:15 UTC by Piyush Chaudhary
Modified: 2017-10-05 12:14 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
register.h file (361.89 KB, text/plain)
2017-10-05 11:33 UTC, Piyush Chaudhary
Details
register.m file (725.35 KB, text/plain)
2017-10-05 11:33 UTC, Piyush Chaudhary
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Piyush Chaudhary 2017-10-05 11:15:10 UTC
output window:
1>  Restoring NuGet packages...
1>  To prevent NuGet from downloading packages during build, open the Visual Studio Options dialog, click on the Package Manager node and uncheck 'Allow NuGet to download missing packages'.
1>  All packages listed in packages.config are already installed.
1>  Connecting to Mac server 192.168.2.33...
1>  No way to resolve conflict between "System.Xml.ReaderWriter, Version=4.1.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" and "System.Xml.ReaderWriter, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a". Choosing "System.Xml.ReaderWriter, Version=4.1.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" arbitrarily.
1>  Consider app.config remapping of assembly "System.Threading, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "4.0.0.0" [C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Threading\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Threading.dll] to Version "4.0.10.0" [C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\Xamarin.iOS\v1.0\Facades\System.Threading.dll] to solve conflict and get rid of warning.
1>  Consider app.config remapping of assembly "System.Globalization, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "4.0.0.0" [C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Globalization\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Globalization.dll] to Version "4.0.10.0" [C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\Xamarin.iOS\v1.0\Facades\System.Globalization.dll] to solve conflict and get rid of warning.
1>  Consider app.config remapping of assembly "System.Xml.ReaderWriter, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "4.0.0.0" [C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Xml.ReaderWriter\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Xml.ReaderWriter.dll] to Version "4.1.0.0" [C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\Xamarin.iOS\v1.0\Facades\System.Xml.ReaderWriter.dll] to solve conflict and get rid of warning.
1>  Consider app.config remapping of assembly "System.Runtime.Extensions, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "4.0.0.0" [C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Runtime.Extensions\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Runtime.Extensions.dll] to Version "4.0.10.0" [] to solve conflict and get rid of warning.
1>  Consider app.config remapping of assembly "System.Text.RegularExpressions, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "4.0.0.0" [C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Text.RegularExpressions\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Text.RegularExpressions.dll] to Version "4.0.10.0" [] to solve conflict and get rid of warning.
1>  Consider app.config remapping of assembly "System.Net.Http, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "1.5.0.0" [] to Version "4.0.0.0" [C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\Xamarin.iOS\v1.0\System.Net.Http.dll] to solve conflict and get rid of warning.
1>  Consider app.config remapping of assembly "System.Diagnostics.Debug, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "4.0.0.0" [C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Diagnostics.Debug\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Diagnostics.Debug.dll] to Version "4.0.10.0" [C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\Xamarin.iOS\v1.0\Facades\System.Diagnostics.Debug.dll] to solve conflict and get rid of warning.
1>  Consider app.config remapping of assembly "System.Text.Encoding, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "4.0.0.0" [C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Text.Encoding\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Text.Encoding.dll] to Version "4.0.10.0" [C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\Xamarin.iOS\v1.0\Facades\System.Text.Encoding.dll] to solve conflict and get rid of warning.
1>  Consider app.config remapping of assembly "System.Runtime, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "4.0.0.0" [C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Runtime\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Runtime.dll] to Version "4.0.20.0" [] to solve conflict and get rid of warning.
1>  Consider app.config remapping of assembly "System.IO, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "4.0.0.0" [C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.IO\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.IO.dll] to Version "4.0.10.0" [] to solve conflict and get rid of warning.
1>  Consider app.config remapping of assembly "System.Runtime.InteropServices, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "4.0.0.0" [C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Runtime.InteropServices\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Runtime.InteropServices.dll] to Version "4.0.20.0" [] to solve conflict and get rid of warning.
1>  Consider app.config remapping of assembly "System.Collections, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "4.0.0.0" [C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Collections\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Collections.dll] to Version "4.0.10.0" [C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\Xamarin.iOS\v1.0\Facades\System.Collections.dll] to solve conflict and get rid of warning.
1>C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets(1820,5): warning MSB3276: Found conflicts between different versions of the same dependent assembly. Please set the "AutoGenerateBindingRedirects" property to true in the project file. For more information, see http://go.microsoft.com/fwlink/?LinkId=294190.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\ResourceContractSelection.cs(14,7,14,29): warning CS0105: The using directive for 'System.Threading.Tasks' appeared previously in this namespace
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\AddEditAppointment.cs(11,7,11,29): warning CS0105: The using directive for 'System.Threading.Tasks' appeared previously in this namespace
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\TimesheetListView.cs(17,7,17,29): warning CS0105: The using directive for 'System.Threading.Tasks' appeared previously in this namespace
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Helpers\NotificationHelpers.cs(9,7,9,18): warning CS0105: The using directive for 'ObjCRuntime' appeared previously in this namespace
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\UIExtensions\InlineDateTimeElement.cs(323,27,323,36): warning CS0114: 'InlineDateTimeElement.InlineDateElement.GetHeight(UITableView, NSIndexPath)' hides inherited member 'Element.GetHeight(UITableView, NSIndexPath)'. To make the current member override that implementation, add the override keyword. Otherwise add the new keyword.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeRow.cs(877,28,877,38): warning CS0628: 'ResourceHeader.DayInClear': new protected member declared in sealed class
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeRow.cs(920,24,920,36): warning CS0628: 'ResourceHeader.TimeClearTap(object, EventArgs)': new protected member declared in sealed class
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeEntryView.cs(42,19,42,39): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(19,19,19,39): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Helpers\Shared.cs(64,23,64,43): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Expense\EditExpenseList.cs(123,30,123,32): warning CS0168: The variable 'ex' is declared but never used
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\View Time\ViewTime.cs(121,35,121,110): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\View Time\ViewTime.cs(154,35,154,100): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Expense\AddExpense.cs(611,39,612,98): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Expense\AddExpense.cs(669,39,670,97): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Expense\AddExpenseLineItems.cs(464,39,465,98): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Expense\AddExpenseLineItems.cs(521,39,522,97): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\ExternalLogin.cs(63,39,63,128): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\ExternalLogin.cs(78,39,78,112): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\ExternalLogin.cs(87,35,87,99): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Expense\EditExpenseList.cs(826,39,827,98): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Expense\EditExpenseList.cs(896,39,897,97): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Expense\EditExpenseList.cs(972,30,972,32): warning CS0168: The variable 'ex' is declared but never used
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\AppDelegate.cs(181,13,182,62): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\LocationValidation\Sessions.cs(57,13,57,23): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Milestone\AddMilestone.cs(713,39,714,98): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Milestone\AddMilestone.cs(764,39,765,97): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Helpers\Shared.cs(64,69,64,89): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Helpers\Shared.cs(148,39,148,157): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Helpers\Shared.cs(154,39,154,111): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Helpers\Shared.cs(160,35,160,107): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(19,51,19,71): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(114,35,114,135): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(149,13,149,85): warning CS0618: 'SlideInHelpers.AddSlideUpHeader(UIView, string, EventHandler, string, EventHandler, string)' is obsolete: 'AddSlideUpHeader() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(150,13,150,71): warning CS0618: 'SlideInHelpers.AddSlideUpHtmlPage(UIView, string)' is obsolete: 'AddSlideUpHtmlPage() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(152,39,152,59): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(152,13,152,102): warning CS0618: 'SlideAnimationHelper.SlideIn(UIView, SlideAnimationHelper.Edge, double, double, Action, UIViewAnimationOptions)' is obsolete: 'SlideIn() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeMain.cs(484,105,484,124): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(159,13,159,93): warning CS0618: 'SlideInHelpers.AddSlideUpHeader(UIView, string, EventHandler, string, EventHandler, string)' is obsolete: 'AddSlideUpHeader() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(160,13,160,72): warning CS0618: 'SlideInHelpers.AddSlideUpHtmlPage(UIView, string)' is obsolete: 'AddSlideUpHtmlPage() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(162,46,162,66): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(162,13,162,109): warning CS0618: 'SlideAnimationHelper.SlideIn(UIView, SlideAnimationHelper.Edge, double, double, Action, UIViewAnimationOptions)' is obsolete: 'SlideIn() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(168,55,168,75): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Login\LoginController.cs(168,13,168,130): warning CS0618: 'SlideAnimationHelper.SlideOut(UIView, SlideAnimationHelper.Edge, double, double, UIViewAnimationOptions)' is obsolete: 'SlideOut() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeMain.cs(584,17,609,20): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeMain.cs(566,28,566,45): warning CS1998: This async method lacks 'await' operators and will run synchronously. Consider using the 'await' operator to await non-blocking API calls, or 'await Task.Run(...)' to do CPU-bound work on a background thread.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\AddEditAppointment.cs(81,35,81,100): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeEntryView.cs(42,51,42,71): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\AddEditAppointment.cs(203,27,203,160): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeEntryView.cs(69,13,69,103): warning CS0618: 'SlideInHelpers.AddSlideUpHeader(UIView, string, EventHandler, string, EventHandler, string)' is obsolete: 'AddSlideUpHeader() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\Calendar.cs(411,13,411,42): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\Calendar.cs(422,13,422,42): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\Calendar.cs(443,27,444,60): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\Calendar.cs(441,29,441,48): warning CS1998: This async method lacks 'await' operators and will run synchronously. Consider using the 'await' operator to await non-blocking API calls, or 'await Task.Run(...)' to do CPU-bound work on a background thread.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\CalendarHelper.cs(76,13,76,52): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\CalendarHelper.cs(74,28,74,42): warning CS1998: This async method lacks 'await' operators and will run synchronously. Consider using the 'await' operator to await non-blocking API calls, or 'await Task.Run(...)' to do CPU-bound work on a background thread.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\CalendarHelper.cs(93,13,93,55): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\CalendarHelper.cs(90,28,90,49): warning CS1998: This async method lacks 'await' operators and will run synchronously. Consider using the 'await' operator to await non-blocking API calls, or 'await Task.Run(...)' to do CPU-bound work on a background thread.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeRow.cs(110,13,110,76): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(1103,13,1103,50): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\TimesheetListView.cs(65,17,65,27): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\TimesheetListView.cs(89,17,89,27): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(1149,13,1149,134): warning CS0618: 'SlideInHelpers.AddSlideUpHeader(UIView, string, EventHandler, string, EventHandler, string)' is obsolete: 'AddSlideUpHeader() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(1150,39,1150,59): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(1150,13,1150,114): warning CS0618: 'SlideAnimationHelper.SlideIn(UIView, SlideAnimationHelper.Edge, double, double, Action, UIViewAnimationOptions)' is obsolete: 'SlideIn() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\TimesheetListView.cs(307,99,307,112): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\TimesheetListView.cs(311,105,311,124): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\TimesheetListView.cs(436,25,436,35): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\EditTime.cs(312,17,312,92): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(103,13,103,29): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(116,13,116,34): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(174,29,174,45): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(235,29,235,45): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(258,17,258,42): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(308,17,308,42): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(74,36,74,47): warning CS1998: This async method lacks 'await' operators and will run synchronously. Consider using the 'await' operator to await non-blocking API calls, or 'await Task.Run(...)' to do CPU-bound work on a background thread.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\EditTime.cs(517,27,517,137): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(439,17,439,130): warning CS0618: 'SlideInHelpers.AddSlideUpHeader(UIView, string, EventHandler, string, EventHandler, string)' is obsolete: 'AddSlideUpHeader() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(440,43,440,63): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(440,17,440,118): warning CS0618: 'SlideAnimationHelper.SlideIn(UIView, SlideAnimationHelper.Edge, double, double, Action, UIViewAnimationOptions)' is obsolete: 'SlideIn() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(488,13,488,94): warning CS0618: 'SlideInHelpers.AddSlideUpHeader(UIView, string, EventHandler, string, EventHandler, string)' is obsolete: 'AddSlideUpHeader() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(489,13,489,65): warning CS0618: 'SlideInHelpers.AddSlideUpListView(UIView, TableViewSourceStringList)' is obsolete: 'AddSlideUpListView() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(492,45,492,65): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(492,13,492,102): warning CS0618: 'SlideAnimationHelper.SlideIn(UIView, SlideAnimationHelper.Edge, double, double, Action, UIViewAnimationOptions)' is obsolete: 'SlideIn() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(534,13,534,95): warning CS0618: 'SlideInHelpers.AddSlideUpHeader(UIView, string, EventHandler, string, EventHandler, string)' is obsolete: 'AddSlideUpHeader() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(535,13,535,67): warning CS0618: 'SlideInHelpers.AddSlideUpListView(UIView, TableViewSourceStringList)' is obsolete: 'AddSlideUpListView() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(538,46,538,66): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(538,13,538,103): warning CS0618: 'SlideAnimationHelper.SlideIn(UIView, SlideAnimationHelper.Edge, double, double, Action, UIViewAnimationOptions)' is obsolete: 'SlideIn() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(543,46,543,66): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(543,13,543,103): warning CS0618: 'SlideAnimationHelper.SlideOut(UIView, SlideAnimationHelper.Edge, double, double, UIViewAnimationOptions)' is obsolete: 'SlideOut() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(548,47,548,67): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(548,13,548,104): warning CS0618: 'SlideAnimationHelper.SlideOut(UIView, SlideAnimationHelper.Edge, double, double, UIViewAnimationOptions)' is obsolete: 'SlideOut() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\EditTime.cs(636,33,636,109): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(555,46,555,66): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(555,13,555,103): warning CS0618: 'SlideAnimationHelper.SlideOut(UIView, SlideAnimationHelper.Edge, double, double, UIViewAnimationOptions)' is obsolete: 'SlideOut() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(556,13,556,38): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(564,47,564,67): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(564,13,564,104): warning CS0618: 'SlideAnimationHelper.SlideOut(UIView, SlideAnimationHelper.Edge, double, double, UIViewAnimationOptions)' is obsolete: 'SlideOut() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(567,17,567,52): warning CS0618: 'SlideAnimationHelper.RemoveAnimationEndedHandlers()' is obsolete: 'RemoveAnimationEndedHandlers() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(577,17,577,130): warning CS0618: 'SlideInHelpers.AddSlideUpHeader(UIView, string, EventHandler, string, EventHandler, string)' is obsolete: 'AddSlideUpHeader() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(578,43,578,63): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(578,17,578,118): warning CS0618: 'SlideAnimationHelper.SlideIn(UIView, SlideAnimationHelper.Edge, double, double, Action, UIViewAnimationOptions)' is obsolete: 'SlideIn() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(593,44,593,64): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(593,17,593,101): warning CS0618: 'SlideAnimationHelper.SlideOut(UIView, SlideAnimationHelper.Edge, double, double, UIViewAnimationOptions)' is obsolete: 'SlideOut() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(762,40,762,60): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(762,13,762,97): warning CS0618: 'SlideAnimationHelper.SlideOut(UIView, SlideAnimationHelper.Edge, double, double, UIViewAnimationOptions)' is obsolete: 'SlideOut() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(776,40,776,60): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\AddTimeController.cs(776,13,776,97): warning CS0618: 'SlideAnimationHelper.SlideOut(UIView, SlideAnimationHelper.Edge, double, double, UIViewAnimationOptions)' is obsolete: 'SlideOut() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\UIExtensions\OurMapView.cs(47,17,47,91): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\UIExtensions\DateTimePickerView.cs(39,13,39,98): warning CS0618: 'SlideInHelpers.AddSlideUpHeader(UIView, string, EventHandler, string, EventHandler, string)' is obsolete: 'AddSlideUpHeader() and the SlideInHelpers class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\UIExtensions\DateTimePickerView.cs(48,33,48,53): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\UIExtensions\DateTimePickerView.cs(48,13,48,97): warning CS0618: 'SlideAnimationHelper.SlideOut(UIView, SlideAnimationHelper.Edge, double, double, UIViewAnimationOptions)' is obsolete: 'SlideOut() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\UIExtensions\DateTimePickerView.cs(54,33,54,53): warning CS0618: 'SlideAnimationHelper' is obsolete: 'This class is depricated. Use AnimationHelper.cs instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\UIExtensions\DateTimePickerView.cs(54,13,54,97): warning CS0618: 'SlideAnimationHelper.SlideOut(UIView, SlideAnimationHelper.Edge, double, double, UIViewAnimationOptions)' is obsolete: 'SlideOut() and the SlideAnimationHelper class is depricated. Use AnimationHelper class instead.'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Forms\ServiceAssessment.cs(312,35,313,94): warning CS0618: 'UIAlertView.UIAlertView(string, string, UIAlertViewDelegate, string, params string[])' is obsolete: 'Use overload with a IUIAlertViewDelegate parameter'
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\RouteMap.cs(210,30,210,32): warning CS0168: The variable 'ex' is declared but never used
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\ResourceContractSelection.cs(29,67,29,82): warning CS0169: The field 'ResourceContractSelection.weekRootSection' is never used
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Milestone\AddMilestone.cs(965,36,965,48): warning CS0649: Field 'AddMilestone._customAlert' is never assigned to, and will always have its default value null
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Calendar\RouteMap.cs(30,38,30,61): warning CS0649: Field 'RouteMap.CurrentOptimalSegmented' is never assigned to, and will always have its default value null
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\ResourceContractSelection.cs(29,46,29,65): warning CS0169: The field 'ResourceContractSelection.contractRootSection' is never used
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Forms\ServiceAssessment.cs(52,31,52,40): warning CS0649: Field 'ServiceAssessment.imageView' is never assigned to, and will always have its default value null
1>N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\Timesheets\Add Time\ResourceContractSelection.cs(35,22,35,39): warning CS0414: The field 'ResourceContractSelection.popViewController' is assigned but its value is never used
1>  dotStaffiOS -> N:\Piyush\Projects\DotStaff_ITMS4_290917\dotStaffiOS\bin\iPhone\Debug\dotStaffiOS.exe
1>  Detected signing identity:
1>    Code Signing Key: "iPhone Developer: Amit Patadia (8A9KRKX7LV)" (CCA10462D4F897128E2557A77BA6D974B0595467)
1>    Provisioning Profile: "Infotachus_Dotstaff" (7db4cd78-b14b-42b3-8e15-4371389a7ed9)
1>    Bundle Id: com.dotstaffinfotachus
1>    App Id: V555G8UFF3.com.dotstaffinfotachus
1>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(1381,3): warning : The iCloud entitlement 'com.apple.developer.icloud-container-environment' is not supported by the Provisioning Profile.
1>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(1381,3): warning : The iCloud entitlement 'com.apple.developer.icloud-container-identifiers' is not supported by the Provisioning Profile.
1>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(1381,3): warning : The iCloud entitlement 'com.apple.developer.icloud-services' is not supported by the Provisioning Profile.
1>  Process exited with code 1, command:
1>  /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang  -Wno-receiver-forward-class -gdwarf-2 -I/Library/Frameworks/Xamarin.iOS.framework/Versions/11.0.0.0/SDKs/MonoTouch.iphoneos.sdk/usr/include -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS10.1.sdk -Qunused-arguments -miphoneos-version-min=9.2 -arch arm64 -c -o /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/arm64/registrar.o -x objective-c++ -DDEBUG /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/64/registrar.m
1>  /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/64/registrar.m:4709:8: error: unknown type name 'MKClusterAnnotation'
1>  static MKClusterAnnotation * native_to_managed_trampoline_92 (id self, SEL _cmd, MonoMethod **managed_method_ptr, MKMapView * p0, NSArray * p1, uint32_t token_ref)
1>         ^ 
1>  /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/64/registrar.m:4717:2: error: unknown type name 'MKClusterAnnotation'
1>          MKClusterAnnotation * res = {0};
1>          ^ 
1>  /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/64/registrar.m:14330:4: error: expected a type
1>          -(MKClusterAnnotation *) mapView:(MKMapView *)p0 clusterAnnotationForMemberAnnotations:(NSArray *)p1;
1>            ^ 
1>  /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/64/registrar.m:14392:4: error: expected a type
1>          -(MKClusterAnnotation *) mapView:(MKMapView *)p0 clusterAnnotationForMemberAnnotations:(NSArray *)p1
1>            ^ 
1>  /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/64/registrar.m:14395:10: error: cannot initialize return object of type 'id' with an rvalue of type 'int *'
1>                  return native_to_managed_trampoline_92 (self, _cmd, &managed_method, p0, p1, 0x29604);
1>                         ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
1>  5 errors generated.
1>  Process exited with code 1, command:
1>  /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang  -Wno-receiver-forward-class -gdwarf-2 -I/Library/Frameworks/Xamarin.iOS.framework/Versions/11.0.0.0/SDKs/MonoTouch.iphoneos.sdk/usr/include -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS10.1.sdk -Qunused-arguments -miphoneos-version-min=9.2 -arch armv7 -c -o /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/armv7/registrar.o -x objective-c++ -DDEBUG /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/32/registrar.m
1>  /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/32/registrar.m:4709:8: error: unknown type name 'MKClusterAnnotation'
1>  static MKClusterAnnotation * native_to_managed_trampoline_92 (id self, SEL _cmd, MonoMethod **managed_method_ptr, MKMapView * p0, NSArray * p1, uint32_t token_ref)
1>         ^ 
1>  /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/32/registrar.m:4717:2: error: unknown type name 'MKClusterAnnotation'
1>          MKClusterAnnotation * res = {0};
1>          ^ 
1>  /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/32/registrar.m:14330:4: error: expected a type
1>          -(MKClusterAnnotation *) mapView:(MKMapView *)p0 clusterAnnotationForMemberAnnotations:(NSArray *)p1;
1>            ^ 
1>  /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/32/registrar.m:14392:4: error: expected a type
1>          -(MKClusterAnnotation *) mapView:(MKMapView *)p0 clusterAnnotationForMemberAnnotations:(NSArray *)p1
1>            ^ 
1>  /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/32/registrar.m:14395:10: error: cannot initialize return object of type 'id' with an rvalue of type 'int *'
1>                  return native_to_managed_trampoline_92 (self, _cmd, &managed_method, p0, p1, 0x1AB04);
1>                         ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
1>  5 errors generated.
1>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(748,3): error : Failed to compile the generated registrar code. Please file a bug report at http://bugzilla.xamarin.com
========== Build: 0 succeeded, 1 failed, 2 up-to-date, 0 skipped ==========
Comment 1 Piyush Chaudhary 2017-10-05 11:18:51 UTC
I have updated my xamarin to 4.7.9.45 and also updated xamarion ios for mac to 11.0 with xcode 9. Here I found this issue when I build my ios app on device and it is working fine on simulation. Please do the needful.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2017-10-05 11:22:02 UTC
Can you attach these two files?

> /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/64/registrar.m
> /Users/Admin/Library/Caches/Xamarin/mtbs/builds/dotStaffiOS/e6679641e9c8063f0e6c306304ef7bc9/obj/iPhone/Debug/mtouch-cache/64/registrar.h
Comment 3 Rolf Bjarne Kvinge [MSFT] 2017-10-05 11:25:05 UTC
Actually wait, you're not using Xcode 9:

> /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS10.1.sdk

that's the iOS 10.1 SDK, which shipped with Xcode 8.1.

It looks like you somehow ended up with a wrong Xcode on your system.
Comment 4 Piyush Chaudhary 2017-10-05 11:33:29 UTC
Created attachment 25122 [details]
register.h file
Comment 5 Piyush Chaudhary 2017-10-05 11:33:51 UTC
Created attachment 25123 [details]
register.m file
Comment 6 Piyush Chaudhary 2017-10-05 11:34:32 UTC
I have atteched both the files. Please let me know what should I do to resolve this issue.
Comment 7 Piyush Chaudhary 2017-10-05 11:35:45 UTC
I have installed xcode 9 on my mac machine, so what I need to do to hit the right xcode.
Comment 8 Rolf Bjarne Kvinge [MSFT] 2017-10-05 12:14:26 UTC
If you didn't install Xcode into /Applications/Xcode.app, then you can set the actual path in your IDE's preferences (see: https://developer.xamarin.com/guides/ios/troubleshooting/questions/ios-sdk/)