Bug 59970 - In UWP ListView ItemAppearing event is not working properly.
Summary: In UWP ListView ItemAppearing event is not working properly.
Status: RESOLVED DUPLICATE of bug 58713
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 2.4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-04 20:34 UTC by Kalpesh Chheda
Modified: 2017-10-04 23:08 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample issue project (1.14 MB, application/x-zip-compressed)
2017-10-04 20:34 UTC, Kalpesh Chheda
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 58713

Description Kalpesh Chheda 2017-10-04 20:34:38 UTC
Created attachment 25112 [details]
Sample issue project

In UWP ItemAppearing is showing more items then a screen size.

I have listview with 1..to..1000 items.
Items visible on my screen is 51 and ItemAppearing event fired 255 times.

I have attached sample project also.

And solution to this issue is maybe this.
https://stackoverflow.com/questions/45805044/equivalent-of-itemappearing-in-xamarin-uwp
I don't know how to PR currently but in future I will.
Comment 1 Kalpesh Chheda 2017-10-04 20:35:36 UTC
Its working perfectly on android.
Comment 2 Paul DiPietro [MSFT] 2017-10-04 23:08:19 UTC

*** This bug has been marked as a duplicate of bug 58713 ***