Bug 59969 - Can not create or open a Xamarin.Forms project with Beta and macOS High Sierra
Summary: Can not create or open a Xamarin.Forms project with Beta and macOS High Sierra
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Crash Reporter (show other bugs)
Version: 7.2 (d15-4)
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-04 18:20 UTC by Andreas Klapperich
Modified: 2017-10-05 18:11 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Log files from the MaxBookPro VS 7.2 (d15-4) (15.76 KB, application/zip)
2017-10-04 18:20 UTC, Andreas Klapperich
Details
Log files from the MaxBookPro VS 7.2 (d15-4) + VS 7.1.5 (build 2) with Load and Create thats works (31.24 KB, application/zip)
2017-10-04 18:30 UTC, Andreas Klapperich
Details

Description Andreas Klapperich 2017-10-04 18:20:33 UTC
Created attachment 25106 [details]
Log files from the MaxBookPro  VS 7.2 (d15-4)

I have 2 computers with macOS High Sierra

On both I use VS 7.2 (d15-4)

iMac 10.13.1 Beta (17B25c)
MacBookPro 10.13

On the iMac I can create and open Xamarin.Forms application

But it is not possible to do this with the MacBookPro
Comment 1 Andreas Klapperich 2017-10-04 18:22:12 UTC
iMac VS Infos

=== Visual Studio Community 2017 for Mac (Preview) ===

Version 7.2 Preview (7.2 build 634)
Installation UUID: 63cf97e0-7f98-4bdf-b8c1-d2c0c272f7ce
Runtime:
	Mono 5.4.0.201 (2017-06/71277e78f6e) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 504000201

=== NuGet ===

Version: 4.3.1.4445

=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
Runtime Versions:
	2.0.0
	1.0.0-rc2-3002702
SDK: /usr/local/share/dotnet/sdk/2.0.0/Sdks
SDK Versions:
	2.0.0
	1.0.0-preview1-002702
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.4.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.6
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Xamarin.Android ===

Version: 8.0.0.33 (Visual Studio Community)
Android SDK: /Users/andreas/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
		6.0   (API level 23)
		7.1   (API level 25)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Apple Developer Tools ===

Xcode 9.0 (13247)
Build 9A235

=== Xamarin.iOS ===

Version: 11.2.0.8 (Visual Studio Community)
Hash: 9a9f0541
Branch: d15-4-xi
Build date: 2017-09-20 14:57:51-0400

=== Xamarin Inspector ===

Version: 1.3.2
Hash: 461f09a
Branch: 1.3-release
Build date: Tue, 03 Oct 2017 18:26:57 GMT
Client compatibility: 1

=== Xamarin.Mac ===

Version: 3.8.0.49 (Visual Studio Community)

=== Build Information ===

Release ID: 702000634
Git revision: cab57de4a7f8c07b8d910d14fff83942cd3f02bf
Build date: 2017-10-02 13:18:41-04
Xamarin addins: a8da992c78f7eb65b3cdb3f951c34a30337cab35
Build lane: monodevelop-lion-d15-4

=== Operating System ===

Mac OS X 10.13.1
Darwin 17.2.0 Darwin Kernel Version 17.2.0
    Mon Sep 18 15:44:59 PDT 2017
    root:xnu-4570.20.55~19/RELEASE_X86_64 x86_64
Comment 2 Andreas Klapperich 2017-10-04 18:23:00 UTC
MacBookPro VS Infos

=== Visual Studio Community 2017 for Mac (Preview) ===

Version 7.2 Preview (7.2 build 634)
Installation UUID: e16ca772-3f7f-4d77-af79-361fce7c628e
Runtime:
	Mono 5.4.0.201 (2017-06/71277e78f6e) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 504000201

=== NuGet ===

Version: 4.3.1.4445

=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
Runtime Versions:
	2.0.0
	1.1.1
	1.1.0
	1.0.4
	1.0.0
SDK: /usr/local/share/dotnet/sdk/2.0.0/Sdks
SDK Versions:
	2.0.0
	2.0.0-preview1-005977
	1.0.1
	1.0.0-preview2-1-003177
	1.0.0-preview2-003121
	1.0.0-preview1-002702
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.4.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.6
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Xamarin.Android ===

Version: 8.0.0.33 (Visual Studio Community)
Android SDK: /Users/andreas/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		7.1 (API level 25)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.5
SDK Build Tools Version: 25.0.3

Java SDK: /usr
java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Apple Developer Tools ===

Xcode 9.0 (13247)
Build 9A235

=== Xamarin.iOS ===

Version: 11.2.0.8 (Visual Studio Community)
Hash: 9a9f0541
Branch: d15-4-xi
Build date: 2017-09-20 14:57:51-0400

=== Xamarin Inspector ===

Version: 1.3.2
Hash: 461f09a
Branch: 1.3-release
Build date: Tue, 03 Oct 2017 18:26:57 GMT
Client compatibility: 1

=== Xamarin.Mac ===

Version: 3.8.0.49 (Visual Studio Community)

=== Build Information ===

Release ID: 702000634
Git revision: cab57de4a7f8c07b8d910d14fff83942cd3f02bf
Build date: 2017-10-02 13:18:41-04
Xamarin addins: a8da992c78f7eb65b3cdb3f951c34a30337cab35
Build lane: monodevelop-lion-d15-4

=== Operating System ===

Mac OS X 10.13.0
Darwin 17.0.0 Darwin Kernel Version 17.0.0
    Thu Aug 24 21:48:19 PDT 2017
    root:xnu-4570.1.46~2/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

MFractor 3.01.04
Azure Functions development (Preview) 7.2
NuGet Package Explorer 0.2
NuGet Package Management Extensions 0.12.5
Paket 0.3
Internet of Things (IoT) development (Preview) 7.1
XamlStyler 1.0.4
Comment 3 Andreas Klapperich 2017-10-04 18:30:04 UTC
Created attachment 25108 [details]
Log files from the MaxBookPro VS 7.2 (d15-4) + VS 7.1.5 (build 2) with Load and Create thats works
Comment 4 Matthew Robbins 2017-10-04 21:44:18 UTC
Hi Andreas, This is Matthew Robbins... I'm the author of MFractor.

Just going to jump in here as I can see you are on old version of MFractor (I can see 3.1.4). We had significant issues with the Alpha and Beta streams of VS Mac in these versions that have since been fixed.

Can you update to the latest version of MFractor (3.2.10) and re-test this? Chances are this issue is being caused by some past instability in MFractor.

Thanks! :)
Comment 5 Andreas Klapperich 2017-10-05 18:11:31 UTC
Hi Matthew,

Yes it was MFractor !!!!!

Thanks

Andy


Every things works, than I made the update to High Sierra.....

Note You need to log in before you can comment on or make changes to this bug.