Bug 59966 - Tap in the android navigation bar region does not scroll the content when focus is obtained in Samsung galaxy S8 + device
Summary: Tap in the android navigation bar region does not scroll the content when foc...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-04 16:24 UTC by Ganesan VG
Modified: 2018-01-03 17:03 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Ganesan VG 2017-10-04 16:24:12 UTC
Hi Team,

I am using a simple application where i have a focusable control like an Entry or Editor under the navigation bar region of my Samsung Galaxy S8 + phone. Initially when the application loads and the Navigation bar is visible, and when i touch the last visible line on the screen the focus is obtained and the keyboard pop up opens and the content is scrolled upwards to fit the keyboard. However if i collapse the navigation bar in my phone via a click in the left end of the navigation bar(feature of the Samsung S8 + device). Now that the navigation bar is gone, upon clicking the last line of text in view , the focus is obtained and the keyboard does pop up, but the content is not scrolled and i could not see the content. Please watch the video that i have attached along with the sample for more clarity of the issue. Could you please look into it and provide a solution. Thanks in advance !!
Comment 1 Paul DiPietro [MSFT] 2017-10-04 16:27:09 UTC
Could you attach a reproduction project rather than a video? Actual projects we can run are more helpful to us.
Comment 2 Ganesan VG 2017-10-04 16:37:09 UTC
Hi Paul,

Thanks for the update. Please find the attachment with both the sample and the video from the below link.

http://www.syncfusion.com/downloads/support/directtrac/177747/ze/GalaxyS8824361368
Comment 3 Ganesan VG 2017-10-09 04:22:59 UTC
The required information and sample are provided. So reopen this ticket.
Comment 4 Paul DiPietro [MSFT] 2018-01-03 17:03:30 UTC
I have tested the reproduction with the latest 2.5.0 release on an S8 device and cannot reproduce the behavior. The second editor scrolls up when the bottom bar is hidden. Please reopen a new issue on GitHub with more information if the issue still occurs as of the latest stable release, but at the present time this does not appear to be a problem.