Bug 59965 - MT4109 - PdfKit.h Missing
Summary: MT4109 - PdfKit.h Missing
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools (show other bugs)
Version: XI 11.0 (xcode9)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Xcode9.1
Assignee: Rolf Bjarne Kvinge [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-10-04 15:46 UTC by Graham Hickson
Modified: 2017-10-05 12:24 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Graham Hickson 2017-10-04 15:46:57 UTC
Process exited with code 1, command:
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++  -Wno-receiver-forward-class -Wno-unguarded-availability-new -gdwarf-2 -I/Library/Frameworks/Xamarin.iOS.framework/Versions/11.0.0.0/SDKs/MonoTouch.iphoneos.sdk/usr/include -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS11.0.sdk -Qunused-arguments -miphoneos-version-min=11.0 -arch arm64 -c -o /Users/grahamhickson/Documents/Projects/BackOffice/Mobile/iQMobile/iQ.Mobile/iQ.Mobile.iOS/obj/iPhone/Release/mtouch-cache/arm64/registrar.o -x objective-c++ /Users/grahamhickson/Documents/Projects/BackOffice/Mobile/iQMobile/iQ.Mobile/iQ.Mobile.iOS/obj/iPhone/Release/mtouch-cache/registrar.m
    In file included from /Users/grahamhickson/Documents/Projects/BackOffice/Mobile/iQMobile/iQ.Mobile/iQ.Mobile.iOS/obj/iPhone/Release/mtouch-cache/registrar.m:2:
    /Users/grahamhickson/Documents/Projects/BackOffice/Mobile/iQMobile/iQ.Mobile/iQ.Mobile.iOS/obj/iPhone/Release/mtouch-cache/registrar.h:15:9: fatal error: 'PdfKit/PdfKit.h' file not found
    #import <PdfKit/PdfKit.h>
            ^~~~~~~~~~~~~~~~~
    1 error generated.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2017-10-04 17:03:39 UTC
Are you using a case-sensitive file system?
Comment 2 Rolf Bjarne Kvinge [MSFT] 2017-10-04 17:11:10 UTC
If you're on a case-sensitive file system, this should fix it: https://github.com/xamarin/xamarin-macios/pull/2841
Comment 3 Graham Hickson 2017-10-05 12:24:50 UTC
Correct, turns out the issue was indeed with case sensitive filesystem.

Reverted development machine to insensitive and builds now finish without error.