Bug 59932 - "Page button" disappears from Navigation Bar when popping back to inserted Page on iOS
Summary: "Page button" disappears from Navigation Bar when popping back to inserted Pa...
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.5.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-03 17:48 UTC by George Josh Karabin
Modified: 2017-12-15 14:36 UTC (History)
3 users (show)

Tags: mdp, navigation, ac
Is this bug a regression?: ---
Last known good build:


Attachments
Reproduction for iOS (154.25 KB, application/zip)
2017-10-03 17:48 UTC, George Josh Karabin
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 59932 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description George Josh Karabin 2017-10-03 17:48:39 UTC
Created attachment 25080 [details]
Reproduction for iOS

Demonstrates a Master-Detail page bug where the "Page button" as shown in the docs (https://developer.xamarin.com/guides/xamarin-forms/application-fundamentals/navigation/master-detail-page/) disappears on iOS if you insert a Page before the Current page in the Navigation stack of the Detail, and then PopAsync to that new page.

Android handles the situation just fine - the "Page button" remains present after the PopAsync. The iOS reproduction does not show what it should (in this case, the title of the Master page, since there is no default icon for that platform).

I have tried many variations on this, with and without adding icons for the page button on iOS. None of them behave differently. As this is the smallest reproduction, I have left it in this state.

This bug is possibly related to https://bugzilla.xamarin.com/show_bug.cgi?id=41085 as well. Both bugs are for applications that have similar structure with the NavigationPage in the detail being used directly.

---

=== Visual Studio Professional 2017 for Mac ===

Version 7.1.5 (build 2)
Installation UUID: f7c6b058-ca10-4406-a8c7-565894bf8552
Runtime:
	Mono 5.2.0.224 (d15-3/14f2c81) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 502000224

=== NuGet ===

Version: 4.3.0.2418

=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
Runtime Versions:
	1.1.1
	1.0.4
SDK: /usr/local/share/dotnet/sdk/1.0.3/Sdks
SDK Version: 1.0.3
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.2.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.5
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Xamarin.Android ===

Version: 7.4.5.1 (Visual Studio Professional)
Android SDK: /Users/e840944/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)
		7.1   (API level 25)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 26.0.0
SDK Build Tools Version: 25.0.3

Java SDK: /usr
java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Apple Developer Tools ===

Xcode 9.0 (13247)
Build 9A235

=== Xamarin.iOS ===

Version: 11.0.0.0 (Visual Studio Professional)
Hash: 152b654a
Branch: xcode9
Build date: 2017-09-15 02:25:56-0400

=== Xamarin.Mac ===

Version: 3.6.3.3 (Visual Studio Professional)

=== Xamarin Inspector ===

Version: 1.3.1
Hash: cbc48dd
Branch: 1.3-release
Build date: Thu, 21 Sep 2017 19:52:53 GMT
Client compatibility: 1

=== Build Information ===

Release ID: 701050002
Git revision: 7afedcaef8e7542e70e3cf8f9bdb26938b8c0876
Build date: 2017-09-15 08:39:58-04
Xamarin addins: 3262aadf811a18c12eac6742532d052b0139a808
Build lane: monodevelop-lion-d15-3-xcode9

=== Operating System ===

Mac OS X 10.12.6
Darwin 16.7.0 Darwin Kernel Version 16.7.0
    Thu Jun 15 17:36:27 PDT 2017
    root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Gist Ide Information 1.1.0
NuGet Package Management Extensions 0.12.3
xUnit.NET 2 testing framework support 0.7.5
Comment 1 Adam Hartley [MSFT] 2017-12-14 10:48:47 UTC
I was able to confirm that this issue is still present on Forms 2.5 following the steps outlined above.
Comment 2 George Josh Karabin 2017-12-15 14:36:12 UTC
Thanks. This is still an issue for my team, for what it's worth, blocking iOS deployments of some of our apps.