Bug 59908 - AssemblyTest.GetReferencedAssemblies() fails on Android
Summary: AssemblyTest.GetReferencedAssemblies() fails on Android
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2017-10-03 01:34 UTC by Jonathan Pryor
Modified: 2017-10-06 14:24 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jonathan Pryor 2017-10-03 01:34:38 UTC
Context: https://github.com/xamarin/xamarin-android/pull/872

The xamarin-android repo will begin using Mono's new NUnitLite infrastructure for unit tests. Instead of "including" many of mono's BCL unit tests into a separate test project, xamarin-android will directly use the mono-built test assemblies from:

> make -C mcs/class/corlib PROFILE=monodroid test

Unfortunately, not all tests pass as-is when running on Android.

The `MonoTests.System.Reflection.AssemblyTest.GetReferencedAssemblies()` test fails when run in this environment, as `AssemblyName.Flags` has a value of `AssemblyNameFlags.PublicKey`; the test expects a value of `AssemblyNameFlags.None`:

https://jenkins.mono-project.com/job/xamarin-android-pr-builder/1720/testReport/(root)/AssemblyTest/GetReferencedAssemblies

I do not know why this test is failing.
Comment 1 Marek Safar 2017-10-06 12:06:12 UTC
I could not reproduce it but made blind fix based on unknown nature of Xamarin.Android.NUnitLite.dll https://github.com/mono/mono/pull/5720
Comment 2 Marek Safar 2017-10-06 14:24:59 UTC
Fixed in master