Bug 59892 - Unable to set MainInterface on a new project
Summary: Unable to set MainInterface on a new project
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 4.8.0 (15.5)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-02 13:42 UTC by Kraig Spear
Modified: 2017-10-06 17:40 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Kraig Spear 2017-10-02 13:42:59 UTC
1. Create a new blank iOS project
2. Create a new Storyboard / UIViewController
3. Open info.plist to set the startup interface
4. Select the desired item from the list

Run the project

Bug:

The selected item isn't the main interface, in fact, there is a crash.

Go back to the info.plist

Notice that there isn't an item selected.

The bug seems to be that if there isn't a key for UIMainStoryboardFile then it will not be created modified. 
If the key is added manually then everything works, and it can be updated.

It also might be a good idea to have QA test the project templates for oddities.
Comment 1 Emanuel 2017-10-06 17:40:24 UTC
Hi Kraig! 
This bug is already fixed in our 15.4 preview 3 release.

Thanks for reporting!