Bug 59873 - Tap Gesture Recognizers not firing on frames
Summary: Tap Gesture Recognizers not firing on frames
Status: RESOLVED DUPLICATE of bug 59961
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: E.Z. Hart [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-09-29 20:43 UTC by Cameron
Modified: 2017-10-13 14:55 UTC (History)
5 users (show)

See Also:
Tags:
Is this bug a regression?: Yes
Last known good build:


Attachments
Repro attempt (297.79 KB, application/x-zip-compressed)
2017-09-29 21:47 UTC, E.Z. Hart [MSFT]
Details
Repro attempt using support libraries v25 (302.29 KB, application/x-zip-compressed)
2017-10-02 22:24 UTC, E.Z. Hart [MSFT]
Details

Description Cameron 2017-09-29 20:43:08 UTC
I just updated my project to Xamarin Forms 2.4 and my TapGestureRecognizers I had added to all my Frames are not firing at all. I downgrade to Xamarin Forms 2.3.4.270 and they work just fine. They don't fire on iOS and Android. I don't think I am doing anything super fancy. They are just on a content page inside a stack layout. See my code snippet below. BtnLogin is a readonly Frame with some text and icon.

var loginTap = new TapGestureRecognizer();
loginTap.Tapped += LoginTap_TappedAsync;
btnLogin.GestureRecognizers.Add(loginTap);

Thanks
Comment 1 E.Z. Hart [MSFT] 2017-09-29 21:47:10 UTC
Created attachment 25044 [details]
Repro attempt

Cameron,

I've been trying to reproduce your issue, but so far I haven't been successful. I've attached a repro project which I think matches what you describe, but the tap gestures *are* firing. Could you take a look and tell me what I'm missing?

Thanks.
Comment 2 Philipp Sumi 2017-09-30 12:26:34 UTC
Cameron, I reported a similar issue, but in my case, I found out that the gesture recognition just got super brittle. If you try tapping really just with your fingertip, with a 90% angle and very quickly, do your events fire?

In my case, it's that "micro-swipes" are no longer registered as taps, I have to really be super-careful with tapping, and then the recognizer fires.
Comment 3 E.Z. Hart [MSFT] 2017-10-02 19:08:38 UTC
(In reply to Philipp Sumi from comment #2)
> Cameron, I reported a similar issue, but in my case, I found out that the
> gesture recognition just got super brittle. If you try tapping really just
> with your fingertip, with a 90% angle and very quickly, do your events fire?
> 
> In my case, it's that "micro-swipes" are no longer registered as taps, I
> have to really be super-careful with tapping, and then the recognizer fires.

Phillipp,

Can you run the attached project and tell me whether you're seeing the same issue?
Comment 4 Cameron 2017-10-02 20:30:28 UTC
(In reply to E.Z. Hard from comment #3)

Hi E.Z. I downloaded and ran your project and it worked for me. The only difference between mine and yours is that I am running v 25.4.0.2 for Xamarin.Android.Support packages.

Thanks
Comment 5 Cameron 2017-10-02 20:34:57 UTC
(In reply to Philipp Sumi from comment #2)

I am using the visual studio emulator for android on windows with a mouse and it was not working.

Thanks
Comment 6 E.Z. Hart [MSFT] 2017-10-02 22:24:12 UTC
Created attachment 25062 [details]
Repro attempt using support libraries v25

Cameron,

I've uploaded a version of my repro project using the 25.4.0.2 support libraries. I appears to still be working - does that version of the project work for you?
Comment 7 Cameron 2017-10-03 20:27:14 UTC
(In reply to E.Z. Hard from comment #6)

Yes that does work for me. In my project though I have a static helper class that generates the Frame for me. Is that why it doesn't work? It worked in earlier versions.

Thanks
Comment 8 post4me3 2017-10-03 23:34:37 UTC
I have exactly the same issue and it seems to be ANDROID related - whereby Tap Gestures tied to :

Labels
Images
Grids
StackLayouts 

used to work in XF 2.3.4.270 without any problems.

Now its a pain to try and interact with the app - previously you could just take your finger and LITERALLY tap on ANY view that had a GR attached, now the only way to get this working is you  CANNOT tap, you have to PRECISELY lower your finger onto the control that has GR enabled and gently press the control ....

I'm testing on a LIVE device (Samsung S8+) , not simulators as simulators with mouse gesture will not show you properly the issue.

All GR in our app are XAML based - absolutely zero codebehind for GR's.

Furthermore, all popup windows that we use which allow the popup to be dismissed by touching the background parent contentview no longer work , i.e we cannot dismiss the window - only way to do this is to use the hardware backbutton.

Android support libs are 25.3.1 respectively.

Downgrading to XF 2.3.4.270 works perfectly.
Comment 9 E.Z. Hart [MSFT] 2017-10-06 16:32:42 UTC
This appears to be another manifestation of https://bugzilla.xamarin.com/show_bug.cgi?id=59961.

*** This bug has been marked as a duplicate of bug 59961 ***

Note You need to log in before you can comment on or make changes to this bug.