Bug 59853 - Clean target fails to remove a FileListAbsolute.txt file in d15-5
Summary: Clean target fails to remove a FileListAbsolute.txt file in d15-5
Status: RESOLVED UPSTREAM
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: 8.1 (15.5)
Hardware: All All
: Normal normal
Target Milestone: 15.6
Assignee: Ankit Jain
URL:
Depends on:
Blocks:
 
Reported: 2017-09-29 14:51 UTC by Peter Collins
Modified: 2018-01-22 18:19 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: d15-4

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description Peter Collins 2017-09-29 14:51:59 UTC
Building and then cleaning a simple forms project is leaving behind a new artifact in d15-5, resulting in a non-empty obj and bin file after invoking clean:

> /obj/Debug/WorkingWithStyles.Android.csproj.FileListAbsolute.txt

On a related note, I should mention again Bug #58174 which is tracking an extra *csproj.CopyComplete which is also not cleaned up appropriately. Both bugs are reproducible on Mac and Windows, and the same repro steps from Bug #58174 apply here:

## Steps to reproduce ##
1) nuget restore WorkingWithStyles/WorkingWithStyles.sln 
2) msbuild /t:SignAndroidPackage WorkingWithStyles/Android/WorkingWithStyles.Android.csproj
3) Take note of content in WorkingWithStyles/Android/obj/Debug/
4) msbuild /t:Clean WorkingWithStyles/Android/WorkingWithStyles.Android.csproj
5) Again take note of content in WorkingWithStyles/Android/obj/Debug/
6) Observe leftover file `WorkingWithStyles.Android.csproj.CopyComplete`

## Environment ##
Operating System: Mac OS X 10.12.3
Repo Name: monodroid
Branch Name: d15-5
Build Revision: 12e1ed307ba15f186f2a2363815a5bf195c41370
Comment 1 dean.ellis 2017-10-03 15:36:37 UTC
@peterc

FileListAbsolute.txt and .CopyComplete are msbuild file, its not something the android team manages. So this is an msbuild bug.
Comment 2 Ankit Jain 2018-01-18 21:37:24 UTC
re:FileListAbsolute.txt, I tested with 5.4.1.7 and 5.2.0.224 but could not reproduce this.
Comment 3 Ankit Jain 2018-01-18 21:41:53 UTC
re:CopyComplete, https://github.com/Microsoft/msbuild/pull/2878 .
Comment 4 Ankit Jain 2018-01-22 18:19:12 UTC
Upstream PR has been merged. And we should have it in mono's msbuild shortly.