Bug 59841 - 'An unhandled exception occurred while processing the request' appears in the web page when debugging ASP.NET Core 1.0 web application
Summary: 'An unhandled exception occurred while processing the request' appears in the...
Status: RESOLVED ANSWERED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: .NET Core support (show other bugs)
Version: 7.2 (d15-4)
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Matt Ward
URL:
Depends on:
Blocks:
 
Reported: 2017-09-29 10:31 UTC by Juliet
Modified: 2017-10-02 08:47 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Compare expect and actual result (497.87 KB, image/png)
2017-09-29 10:31 UTC, Juliet
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Juliet 2017-09-29 10:31:18 UTC
Created attachment 25023 [details]
Compare expect and actual result

Repro Steps:
1. Create an ASP.NET Core Web 1.0 Application.
2. Debug this project.

Expect:
The web page shows well.

Actual:
'An unhandled exception occurred while processing the request' appears in the web page.

More info:
This issue doesn't reproduce after enable docker (Debug docker-compose project).

Visual Studio Community 2017 for Mac (Preview)
Version 7.2 Preview (7.2 build 627)
Installation UUID: 9b4c08eb-14c1-425e-8a78-159d89d2aacc
Runtime:
	Mono 5.4.0.201 (2017-06/71277e78f6e) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 504000201

NuGet
Version: 4.3.1.4445

.NET Core
Runtime: /usr/local/share/dotnet/dotnet
Runtime Versions:
	2.0.0
	1.1.2
	1.0.5
SDK: /usr/local/share/dotnet/sdk/2.0.0/Sdks
SDK Versions:
	2.0.0
	1.0.4
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.4.0/lib/mono/msbuild/15.0/bin/Sdks

Xamarin.Profiler
Version: 1.5.6
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

Apple Developer Tools
Xcode 9.0 (13247)
Build 9A235

Xamarin.iOS
Version: 10.14.0.26 (Visual Studio Community)
Hash: 416f778f
Branch: d15-4
Build date: 2017-08-25 17:30:05-0400

Xamarin.Android
Version: 7.5.0.15 (Visual Studio Community)
Android SDK: /Users/bys/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		6.0 (API level 23)
		7.1 (API level 25)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.5
SDK Build Tools Version: 25.0.3

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

Xamarin.Mac
Version: 3.8.0.26 (Visual Studio Community)

Xamarin Inspector
Version: 1.3.1
Hash: cbc48dd
Branch: 1.3-release
Build date: Thu, 21 Sep 2017 19:52:53 GMT
Client compatibility: 1

Build Information
Release ID: 702000627
Git revision: fcce41475a61731548efa58ab265cc9f3b5cbab6
Build date: 2017-09-28 11:48:55-04
Xamarin addins: 9869b03437bfe2410b4cafda1ba8b4334715e369
Build lane: monodevelop-lion-d15-4

Operating System
Mac OS X 10.12.6
Darwin 16.7.0 Darwin Kernel Version 16.7.0
    Thu Jun 15 17:36:27 PDT 2017
    root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64
Comment 1 Juliet 2017-09-30 01:57:49 UTC
More information:
The web page shows well when debugging ASP.NET Core Web 2.0/1.1 Application.
Comment 2 Matt Ward 2017-10-02 08:47:09 UTC
Unable to repro this. The error looks like the error you get when OpenSSL is not installed:

https://github.com/dotnet/corefx/issues/9171
https://docs.microsoft.com/en-us/dotnet/core/macos-prerequisites?tabs=netcore1x