Bug 59836 - Changes to XIB/Storyboard not reflected in project
Summary: Changes to XIB/Storyboard not reflected in project
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: Trunk
Hardware: Macintosh Mac OS
: Normal major
Target Milestone: 15.4
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2017-09-28 23:51 UTC by Don Jordan
Modified: 2017-10-04 12:56 UTC (History)
5 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Don Jordan 2017-09-28 23:51:48 UTC
Changes made to a XIB or Storyboard in XCode 9 do not get reflected in Xamarin after returning to VSMac.  Git doesn't even show a file change when files in the obj folder are ignored.  After experimenting, it seems that the temporary version of the file created for the XCode project when you open Interface Builder is getting changed but it is not getting moved over when XCode is closed or focus is given back to VSMac.  I verified this by manually copying the temp file to the normal location and the changes came through just fine.

=== Visual Studio Professional 2017 for Mac ===

Version 7.1.5 (build 2)
Installation UUID: 380f07b5-4345-4f1a-a8fc-6e9d3bebfbee
Runtime:
	Mono 5.2.0.224 (d15-3/14f2c81) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 502000224

=== NuGet ===

Version: 4.3.0.2418

=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
Runtime Versions:
	1.1.1
	1.0.4
SDK: /usr/local/share/dotnet/sdk/1.0.3/Sdks
SDK Version: 1.0.3
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.2.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.5
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 9.0 (13247)
Build 9A235

=== Xamarin.iOS ===

Version: 11.0.0.0 (Visual Studio Professional)
Hash: 152b654a
Branch: xcode9
Build date: 2017-09-15 02:25:56-0400

=== Xamarin.Android ===

Version: 7.4.5.1 (Visual Studio Professional)
Android SDK: 
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)
		7.0   (API level 24)
		7.1   (API level 25)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.6
SDK Build Tools Version: 25.0.3

Java SDK: /usr
java version "1.8.0_111"
Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Inspector ===

Not Installed

=== Xamarin.Mac ===

Version: 3.6.3.3 (Visual Studio Professional)

=== Build Information ===

Release ID: 701050002
Git revision: 7afedcaef8e7542e70e3cf8f9bdb26938b8c0876
Build date: 2017-09-15 08:39:58-04
Xamarin addins: 3262aadf811a18c12eac6742532d052b0139a808
Build lane: monodevelop-lion-d15-3-xcode9

=== Operating System ===

Mac OS X 10.12.6
Darwin 16.7.0 Darwin Kernel Version 16.7.0
    Thu Jun 15 17:36:27 PDT 2017
    root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64
Comment 1 Jeffrey Stedfast 2017-09-29 14:51:50 UTC
Seems to be fixed already in v7.2

Note You need to log in before you can comment on or make changes to this bug.